Add to Emma Group Button on Reports

  • 1
  • Idea
  • Updated 11 months ago
From what I've seen and read thus far, you can only import contacts from a Salesforce report to a new emma group? Is that correct?

It'd be ideal to add to existing groups from reports as well.

This could be done via a button on the reports page. Something like Add to Emma Group?

I've uploaded a screenshot of where I'm talking about. It would function similar to that of the Add to Campaign button. Make sense?

Photo of Josh Collins

Josh Collins

  • 30 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1695 Posts
  • 135 Reply Likes
Hey Josh!  Thanks so much for this, it's a great idea to have a button there for that.  It certainly would create a more streamlined way of doing that.  

I did want to clarify that the functionality that you're looking for is actually already available, it’s not actually the case that you can only import the data from a Salesforce report to a NEW Emma Group.

You can pull the additional leads/contacts from the report data into the existing Emma Group by opening the group in the Emma Groups tab, clicking to edit the group and then reselecting the report. While no one is removed from the existing group even if they’re no longer included in the report data, any additional leads/contacts ARE added to the existing group. (the same way importing a spreadsheet to an existing group in Emma works)

But the idea of having a button on the report itself to make that more streamlined is a great feature request!

Cheers!

- Grey 
Photo of Josh Collins

Josh Collins

  • 30 Posts
  • 1 Reply Like
Thanks Grey! As I was continuing to play around in the system after I posted that comment, I did finally understand how to edit and then add as well, so that's a HUGE help to me! Now if only I could understand why I continue to get so many errors... :)
Photo of Ann Brainerd

Ann Brainerd

  • 18 Posts
  • 2 Reply Likes
Hi - I am currently trying to add contacts from a report and it says I
do not have "member ID" as a column.  I add "Emma Member ID" and save the report, but continue to get the same message.  That was the only field called member id.  Does it take some time to refresh before reading that field?

Thanks, Ann
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1694 Posts
  • 135 Reply Likes
Hi Ann, the field you're looking for is actually not the "Emma Member ID" field.  

When creating Emma groups in Salesforce based on reports, said report has to have the ID column for the type of report it is (so either Lead or Contact ID column).  

Go ahead and add that one and give it another shot.  

Let me know if you have any questions!

- Grey