Bold-face text doesn't show up... well, sometimes it does.

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I sure wish I could figure out why text that I make bold sometimes shows up that way in my emails, and sometimes does not. You'd think it would be pretty consistent. Windows 7, Firefox 36.0.
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes

Posted 3 years ago

  • 0
  • 1
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- Formatting can be a little bit tricky when working with pasted text or links. If you're applying the bold formatting to links in your mailing, you'll want to be sure to first link the text and then apply the bold styling. This order is important in helping the bold stick to that linked text.

Anytime you're working with pasted text, formatting can build up behind the scenes in the HTML. If you have text that isn't holding the bold in your tests, you can try using the remove formatting button to strip that text of all styling and start from scratch. This will get rid of any formatting that may have snuck through from the original source of the text...


I'm happy to take a look at a specific mailing if you want to send those details along here!
Photo of Historic Apalachicola Main Street

Historic Apalachicola Main Street

  • 2 Posts
  • 0 Reply Likes
I'm at my wit's end with the same issue. Even after I enter the hyperlink first, then add formatting, after removing formatting, or completely deleting and retyping text so as not to have pasted formatting issues, some of my bold text comes through, some doesn't. I'm about to just remove all the bold from my entire e-newsletter so it will be consisitent.
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
Same here!! There seems to be no consistency whatsoever to this and it's very frustrating and doesn't make anyone look good. I suppose it could be an Outlook problem, since that's what we virtually always view our emails in, but I'm not sure. Either way, you'd think it would be more controllable. I've never seen other e-communications with this issue.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi to both of you -- I hate to see that this is an ongoing issue that you're both dealing with. Let's start by establishing a few details and confirming the steps you're taking and in what order.

Are you using Outlook as your email client? If not, what email client are you testing to?

What plaintext editor are you using or how are you stripping the formatting on your text?

Outlook does have a hard time rendering formatted links. To combat that, you want to follow these steps in order:
  1. Paste in plain text or type directly into the editor
  2. Hyperlink your text
  3. Format your text 
I've actually done tests to Outlook where I have linked and formatted two lines of text in two different orders. The formatted then linked text does not hold its formatting in the inbox, while the linked then formatted text typically does. 

I'll be much more prepared to troubleshoot this issue for you if you can answer my questions above. If you have any screenshots of these inbox inconsistencies, I'd love to see those as well. 

Thanks!
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
Emily, yes, I'm in Outlook; I'm using Microsoft's Notepad to paste my text into (from other sources) then copying that and pasting that unformatted text into MyEmma. I've tried linking first, then bolding/italicizing, and I've done it the other way around too. I don't even seem to get Consistent results regardless of which way I approach it.

I just tried an all-new test. I copied and pasted a column of text FROM a recent MyEmma newsletter into my Notepad editor window (which I assume un-formats all text). I then copied it again from the Notepad file and pasted it into MyEmma -- with no formatting evident. I then hyperlinked the selected pieces of text, and then bold-faced those same pieces of text. I then italicized some other lines. As you can see in the attached image, all the italicizing worked fine but the only piece of text that successfully hyperlinked AND bold-faced was the "New $37M science building" line. All the other hyperlinked lines WERE made bold -- but as you can see, none of them came out bold. Very bizarre that one worked and four others didn't...
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Great, thanks for providing those details and taking the time to build that example for me! If Notepad is anything like Text Edit, the native Mac alternative, you have to manually choose to convert text to plaintext (or you can set it as a default).



I did some research on Notepad but am finding that information to be a bit elusive. :) Just to rule that out, would you mind recreating the same example above using editpad.org instead of Notepad? I can confirm that this free online tool does indeed convert your pasted text to plaintext by simply pasting it in and copying it out.
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
I always apply the bolding after applying the link just as a matter of practice. (I've done it both ways -- nothing seems to be consistent.) Any one of our recent mailings, I'm sure, has many examples. Additionally, virtually all of the text I'm working with has been pasted from a text-editor, not a formatted source like Word, etc.
(Edited)
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
I'm hoping this is still on your radar; I continue to try everything I can think of to remedy this, and, as evidenced in today's latest 'Works" mailing, in the Member News section on the right, all of the headlines there are set as bold text in my layout, but they only sporadically come out as bold in my received emails -- sometimes it works, sometimes it doesn't -- it's not like the bold-face formatting never works. It only SOMETIMES works. I see no pattern or consistency to it whatsoever. Can you take a look again?
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- There are two main factors in play here. The order you link and style that text as well as any formatting that is being pasted in with that text. I did a quick test in your lastest Works email (see my emma copy in Unsent) and had promising results! 

In taking a look at the code behind those links using the </> button on the formatting toolbar, I can see that you did in fact apply the link first and then the bold on those links. This puts the <strong> tag within the link structure instead of outside it, which is how Outlook prefers things. I also noticed a font-weight: inherit styling in the link tags, which may have come in with pasted text. I believe those tags were confilcting.

I used the remove formatting button on two of your links - the first and last links in that right column. This removed the font-weight: inherit tag from those links in the code. I then applied the bold styling again and sent a test to Outlook 2007, 2010 and 2013. In that test, just the first and last links that I manipulated are coming through as bold. 

So, I'd say the best approach moving forward is to strip formatting on that text before linking and then styling the links. Let me know how that goes!
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
Thanks very much, Emily -- I'll go through this process again, but regarding your point about removing formatting: I only paste unformatted text into my MyEmma newsletter layouts (often originating in Word when sent to me, but I always copy and paste it into my NotePad program (which removes all formatting, as I understand) and then paste it into MyEmma. Maybe I'm mistaken about that, but NotePad seems to work in that exact way (having no formatting) in other applications where I use it. Then, as I probably mentioned before, I select the pasted text, add the link, and then, while it's still selected, add the Boldface attribute to it. That's what I thought I'd been instructed to do -- link first, then bold. Although I get that, if there's any kind of type spec associated with it in the code, it'll mess it up.

I just went to MyEmma and sent myself the Test "Works" email you worked on, and got the same (desired) result you got. So that's good.

I guess my only question is, is there a way to paste the text into the layout (like I thought I was doing with NotePad) that will already have "no formatting" to it? Or is there no reliable way to do that, and I have to strip all the formatting within MyEmma prior to applying my type effects?

Thanks again!
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Great! I'm glad we're making progress here. I don't believe that NotePad makes your copy plaintext by default, but might have an option to do so. You can try editpad.org! Just paste your text there and copy it back out to insert plaintext into your mailing. 

Let me know if you see improvement there!
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
Thanks, Emily -- wow, maybe I've been using NotePad all this time under false assumptions. (And if it retains formatting to some degree, why would anyone use it???). I'll probably skip the EditPad.org step because, well, if I'm going to have another step in the process, it might as well be within MyEmma (where I select the text to strip all formatting from it). Anyway, still testing on my end, and I'm guessing you've pointed me in the right direction. I'll report back; thanks.
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
Yes, it appears that NotePad was the issue -- I'm now getting just what I want when I use the MyEmma "remove formatting" button -- and as you said, the hyperlink has to be added before the bold-face tag. Doing it in the other order does not give me bold text in my received newsletter. On text that I'd placed directly from NotePad, the results weren't what I wanted or expected.

Anyway, I think we're good -- thanks very much. And say hi to Emma for me.

- Sean
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
Emily, I'm at a loss -- I was getting the same non-bolding issue yesterday and today in sending myself some final proofs of our latest Works newsletter -- and the top-four Member News items on the right were still not showing up as bold. So I went in, removed the bold, removed the link, even removed formatting, and then RE-linked them, RE-bolded them, and they STILL are not showing up in my received newsletter as bold. What am I doing wrong??? Quite aggravating -- although I'm probably the problem....
(Edited)