Cannot undo manual e-mail opt-out in Salesforce

  • 1
  • 1
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
I was testing the opt-out field on my record in Salesforce and manually checked it. Now when I try to uncheck it and then save the change, it goes back to checked. Is there a way for me to undo this? I didn't mean to opt myself out. I was just testing a workflow.
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes

Posted 4 years ago

  • 1
  • 1
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Official Response
Hi Shari -- You'll need to opt yourself back into your Emma account using the traditional methods and let that sync over to your Salesforce account. You can either email/call us to opt your address back in or you can simply sign-up again via one of your sign-up forms and click the opt-in confirm link in your email.

Moving forward, you'll want to opt contacts out in Emma and let it sync over to Salesforce. That field in Salesforce, if set up correctly, should be read only. I hope this helps!
Photo of Ann Brainerd

Ann Brainerd

  • 18 Posts
  • 2 Reply Likes
Hi Emily -

I have a similar issue.  In this case a contact opted out for their personal email and then signed up using a work email.  Doing this added him as a lead.  I finally got the two to merge, but the "Email Opt Out" button is still checked.  Since he is a regular volunteer and donor with lots of activities, I cannot just delete him and add him back in. 
Now that I've merged the lead I am afraid he will not receive any emails.  Is there a work around?
 
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hi Emily, I checked in with one of my Salesforce folks and this is what they had to throw out there:

This happens because during setup we instruct you to set the opt out field as read-only in SF for security reasons. So there are two workarounds here:

A) First go into Emma and see if that new work email contact is opted out in Emma.  If so, you can have them opt them back using OUR STANDARD METHODS and that should sync back to SF. 

B) You can temporarily go into the Field Accessibility in Salesforce setup and make the opt out field non read-only temporarily, uncheck the opt out box, than make it read-only again once its saved.

Let me know if you have any additional questions on this! 

Cheers!

- G
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
Shari again on this topic... I went to the field accessibility for the Opt-Out field in Salesforce and it currently says "editable" yet I can't uncheck it (it was checked manually). Yet in Emma the contact is Active. What should I do? This has been the case for a while and Emma has not synced the Active status to Salesforce.
Photo of Andrew Heuback

Andrew Heuback, Official Rep

  • 142 Posts
  • 12 Reply Likes
Hey Shari!

This data should be syncing over. To confirm that oauth is connected, please have a System Admin complete these steps in Salesforce:

1. Navigate to the Emma Setup tab and click Start Setup.
2. On step one, click the Connect to Salesforce button.
3. On the pop-up, enter your Emma username and password.
4. After entering those credentials on the pop-up, click to give access permission to the integration and then close the pop-up once you get the success message.
5. Click through the remaining steps of the setup and on the last page, select the button to Complete Setup.

It also sounds like your field accessibility settings may need to be reconfigured. Please go ahead and grant us login access so I can hop in to your org:

https://support.e2ma.net/Resource_Center/Guide_to_Integrations/Emma_for_Salesforce%3A_Support_Access

Let me know once you've done so and I'll take a further look!

(Edited)
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
Hi Andrew, I did all the steps. Now it seems that a bunch of new Emma members that I added to various groups in Salesforce are not syncing over to my same Emma lists. Could you look into that? Maybe because it needs some time to refresh and sync over since I reconnected it to SF?
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
I did give you access for one week. I'm hoping you can look into this soon since I want to send out a newsletter in the next day or so. I haven't sent one to our constituents in 6 months, and I added a lot of new people that need to get this. Thanks for your help!!!
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
I checked the All Contacts list and it appears they all synced over but do not show first or last names. I use the first name in the e-mail so this is important information. I'm not sure though why SF is showing I have 429 but Emma only shows 415 (this includes opt-outs) total.
Photo of Andrew Heuback

Andrew Heuback, Official Rep

  • 142 Posts
  • 12 Reply Likes
Hey Shari. If you head to Emma Setup > Step 2 of 3: Map your Member Fields, you'll see that none of your fields between Emma and Salesforce are mapped, meaning that information is not syncing:



Map your fields here and then complete the setup. Once the sync is finished, have a look and let me know if you still have further questions!
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
Thanks! That seems to be working. Can I log out of Salesforce while it continues or do I need to stay logged in?
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
It's taking a very long time, maybe because I have a very slow Internet connection (I'm not in the USA).
Photo of Andrew Heuback

Andrew Heuback, Official Rep

  • 142 Posts
  • 12 Reply Likes
Glad to hear that! Yes, you can log out while the sync is in progress.
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
Great! I will also shut off the Internet since I guess things will just go on internally in Salesforce.
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
Hi Andrew, After 24 hours of having Internet off and not being logged into SF, when I checked just now thye syncing had not progressed at all, in fact had given an error on the one batch it had been processing when I logged out of SF and turned off my Internet. My main address list (All Contacts) has not yet synced and I need to send out a newsletter. Can you troubleshoot this for me? I've given you login privileges.
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
Just checked again... now one of the groups that had shown up in the last list (successful group syncs) is no longer showing there. That was "CHC Contacts". Now it's not synced anymore. Please check this! I really need to get out my newsletter soon!!!! Thanks.
Photo of Andrew Heuback

Andrew Heuback, Official Rep

  • 142 Posts
  • 12 Reply Likes
Hey Shari. There were numerous aspects of the Emma for Salesforce setup which were not configured properly, which I've since corrected. I am still looking into the group syncing for you and will check-in with an update as soon as I have one. Thanks!
Photo of Andrew Heuback

Andrew Heuback, Official Rep

  • 142 Posts
  • 12 Reply Likes
Everything appears to be working good on my end, Shari. In looking at the City Harvest Contacts group in Salesforce, the total unique members matches what's in Emma. I've checked several other groups with the same result and confirmed things are syncing both ways. Have a look!
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
I checked Emma and it appears that the first name and last name of my new contacts has not yet synced in the All Contacts list. Is this what you are seeing?

How can I prevent issues in the future? You said there were numerous aspects that were not configured properly. I configured Emma in SF when I first set it up in 2014 but haven't done anything since then. Should I be doing regular updates, and how do I do that? Thanks for all your help.
Photo of Andrew Heuback

Andrew Heuback, Official Rep

  • 142 Posts
  • 12 Reply Likes
Hey Shari!

When I initially looked, none of the fields between Emma and Salesforce were mapped and the default values were not set, the permission for Emma Email Marketing were not set, the opt out and error fields for lead and contact objects weren't set to visible / read-only. These are all things that could affect the syncing between the two platforms, which I've since corrected.

I'm still looking into the syncing with a few of these groups; the majority of the first/last names are synced but there are some that have not. There may be something problematic with these groups/reports. I will reach out the moment I know more (though be advised our offices will be closed until Monday, November 27th, so it won't be sooner than next week).
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
Thanks for checking all these things. It's only the 40 or so new contacts I entered in SF that don't have first and last names. When I entered each into SF I also added them to the Emma groups from the SF contact page. Will you have time today to look again? I have a Thanksgiving email to send and use the first name in the email salutation so this is really a problem. I can always go into Emma and add each name manually to each contact but that's a lot of work. Plus if I do that I'll never know if the problem is corrected.
Photo of Shari

Shari

  • 58 Posts
  • 6 Reply Likes
I added just first names to the 30 contacts without names in the All Contacts list. I also added one new contact to three Emma groups from within SF and the contact immediately synced into all those Emma lists in Emma, and his first and last name also synced over to Emma. So maybe it's just because those other 30 names were added previously? But I would think that when you synced them again after making changes to my SF account that their names would have synced over. I didn't add their last names so that you can continue to troubleshoot. We will know if it worked if their last names sync over. I just needed to enter first names in order to send out a Thanksgiving mailing. Fortunately there were only 30! I will give you access again in Emma so you can check things out on Monday.

Just a note, I had followed your original instructions and matched the fields in the Emma Setup in SF before I synced again. When you started working on it those settings should have still been set up (First Name to First Name, Last Name to Last Name, etc).

Hope your vacation and Thanksgiving were pleasurable!
Photo of Andrew Heuback

Andrew Heuback, Official Rep

  • 142 Posts
  • 12 Reply Likes
Hey Shari! Thanks for your continued patience as we work through this.

At this point, it seems like there may be issues with the Emma installation in your Salesforce org. As you mentioned, this was installed in 2014 but has been updated to the latest version (which is required to work properly); it appears that after the update, some data associated with the older version, related to groups, is causing syncing issues here.

I think the best course of action would be to uninstall the Emma package and then reinstall it. One important note: if you uninstall the package, Emma mailing data will be lost in your Salesforce org (though it will still be available in your Emma account). Once it's reinstalled, future mailing data will be available in your org but the historical data will no longer be there. 

If you're willing to give this a shot, we should connect privately via email as it will require us to exchange important account information. I'll send instructions to the email set as the username for your Emma account and we can take it from there.