Can't edit copy in Firefox and Safari

  • 0
  • 1
  • Question
  • Updated 6 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved

Yes, this is driving me crazy, too -- I'm using Firefox and Safari and I can't edit my own copy -- not just cut-and-paste, but even when I copy an old campaign and try to re-write it. It's not improved since the new improved interface was started. Any progress on this fix yet? Thanks, Sue

Note: This topic was created from a reply on the Odd behavior when writing over existing text topic.
Photo of Big Sister Productions

Big Sister Productions

  • 21 Posts
  • 3 Reply Likes

Posted 6 years ago

  • 0
  • 1
Photo of Kyle Floyd

Kyle Floyd, Official Rep

  • 178 Posts
  • 26 Reply Likes
Thanks for reaching out. I am sorry to hear about the text formatting fight you have been in.

When I am struggling to get text to format properly I like to take a step back and in a way, start over. Luckily this doesn't require re-typing all of the text. Just a bit of copying and pasting. Hopefully these steps will make this a bit easier.

1. Locate the portion of text that you are struggling to format or edit. I usually like to work with one paragraph at a time.
2. Copy that text from Emma and paste it to .
3. In your Emma campaign window, delete the text that you just pasted. Make sure you don't delete before pasting because you don't want to lose your content.
4. Now re-copy the text from and paste it back into your Emma mailing.
5. You should now be able to edit your text and format that portion of text with no trouble.

If you are struggling to edit or format all of your content then you can follow the steps above but with the complete block of text.

Please let us know if there is anything else we can assist with.
I am currently having a similar issue. I copied some text from a portion of my campaign and then deleted it. After creating a new text box, I attempted to paste the text into the new box. Nothing appeared. I have pasted the text into, re-copied using that program, but again nothing appeared when I tried to paste into the new text box in my campaign. I have attempted to use paste shortcut keys as well as going to the edit bar, used editpad as well as textedit programs, nothing seems to work.

I'm not sure what else to do and am dreading having to re-type this copy. Thanks in advance, Sarah.
Finally clued in to the fact that I should try a different browser - used Firefox instead of Safari and pasting text worked just fine (didn't keep the hyperlinks, but I can go in and adjust those).
Photo of Rachel Rogers

Rachel Rogers, Communications Strategist

  • 89 Posts
  • 2 Reply Likes
Hi, Sarah! I just wanted to check back in here make sure you weren't still facing the problems with pasting text. I'm glad to here that you're having success in Firefox, since pasting text certainly should work just fine.

You're definitely taking the right steps there, as far as pasting the copy into before pasting it into Emma. If this problem pops up for you again, let us know the campaign you're working on and what particular portion of the campaign is giving you trouble, and we'll jump in and take a look!
Photo of Larry Jacobs Weight Loss

Larry Jacobs Weight Loss

  • 3 Posts
  • 0 Reply Likes
we are having the following issues
1) in our email visual editor if we cut copy and move it we lose formatting
2) if we copy from another email and paste we lose formatting
3) if we try to correct a link we get a word "null" in the entry section and it will not save a new url
Photo of Rachel Rogers

Rachel Rogers, Communications Strategist

  • 89 Posts
  • 2 Reply Likes
Sorry to hear you're having those issues!

To speak to your first two issues involving pasting and formatting - we issued a new feature in our editor this week that allows you to decided whether or not you paste text into Emma with or without the styles previously applied to the text. We would recommend posting without styles, since formatting coming from another source can sometimes be problematic with the HTML formatting in Emma. We always see the best results when text is pasted without any styles and then reformatted using Emma's editor.

That being said, if you still prefer to paste that text and hold onto it's styles, you have the ability to change it by clicking the new text pasting option which can be seen when you hover over a text block in your campaign.

You'll then be able to select whether you want to paste your text with our without styles. 

If "Paste with styles" is selected, Emma will hold onto whatever formatting it can for you.

To address your issue with not being able to edit a link, I've tested that myself and haven't run into the issue you're experiencing. I'd love to get some more information from you on that, such as the web browser and version that you're using, a name of a specific campaign where you're experiencing the issue, what type of link you're using (is it to a website, a document, an email address, or a survey?), and whether or not you're pasting the link or typing it directly! I know those are a bunch of questions, but the more info we get, the easier it is for us to pinpoint a problem. :)

I hope this helps, and I'll be looking for your reply!