checkboxes are not being updated though data is sent

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Using Gravity Forms plugin, checkboxes are not being updated in the database though all the other fields are fine. Gravity Forms says it is an Emma issue that the data is being sent - verified through logs.

This is the data being sent:

(
    [email] => ai30@ai30.com
    [fields] => Array
        (
            [i-am] => Female
            [how-did-you-hear-about-us] => just looking
            [whats-your-age-range] => 51-65
            [last_name] => ai30
            [primary-salutation] => applied30
        )

    [group_ids] => Array
        (
            [0] => 2529631
        )

The Female checkbox in the database remains blank when I look at the record.
Photo of 15-40 Connection

15-40 Connection

  • 8 Posts
  • 1 Reply Like

Posted 2 years ago

  • 0
  • 1
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hey there 15-40, 

Thanks for reaching out.  

It looks like, for some reason, the data that is coming in to Emma has commas in between each letter :




That is what it looks like in the account.  When I checked the back end, it looked like this:



You may want to have Gravity Forms double-check how they're sending the info in to us.  

Let me know what they say!

- Grey
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hey there,  have you been able to reach back out to Gravity Forms about this?  

Let me know if you get any more info from them! 

- Grey
Photo of 15-40 Connection

15-40 Connection

  • 8 Posts
  • 1 Reply Like
Started with Gravity forms. They said they were sending the data correctly.
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hey, thanks for being patient with me while I was checking in with folks here.  Here was a word I got from one of our developers:

"I found another instance where that was happening and adding brackets around the option seemed to fix it:

for example, "i-am":["Female"]   "

Can you reach back out to Gravity Forms and see if that's something they can add in to their code?