Classic form validation

  • 1
  • Problem
  • Updated 1 year ago
  • Not a Problem
I'm using a classic form and placing via javascript. In order to keep my clients on my site I handled validation via jquery with form validation. It was working fine for a few months but is now broken. Has something changed on your end to prevent handling validation from my side?
Photo of Piazza Hospitality

Piazza Hospitality

  • 4 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1699 Posts
  • 135 Reply Likes
Hey there Piazza Hospitality, thanks for reaching out! 

I'm not aware of any changes on our side, but I'm going to do a bit of digging and see if I come up with anything.  

I'll post back here once I check in with our developers.  Can you point me to the site where I can find your form? 

Cheers!

- Grey 
Photo of Piazza Hospitality

Piazza Hospitality

  • 4 Posts
  • 0 Reply Likes
Hi Grey,

http://www.hotelhealdsburg.com/mailing-list/

Validation script is at the end. Thanks for taking a look at it. 

- Ron
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1699 Posts
  • 135 Reply Likes
Hey there!  Thanks for shooting that over.  

I tested the form on your site and it appears to be working.  I was added to the audience and stayed on your page, etc.  Perhaps there's something I'm missing that is what is broken.  

We haven't had any changes to our forms that would cause any issues that you described.  Have you made any additions or subtractions to the scripts running on your page?   

That's the only thing we could think of.  

Let me know if there's anything we can take a look at on our side!

- Grey 
Photo of Piazza Hospitality

Piazza Hospitality

  • 4 Posts
  • 0 Reply Likes
Hi Grey,

Sorry for the delay in getting back to you. The form itself is working fine but the validation isn't working. So if you don't enter an email address and hit submit there should be an error on the form on our page - instead the page redirects to the Emma site and then displays the error. Before the validation worked to stay on our page/form but now submits regardless.

Thanks,

Ron
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1699 Posts
  • 135 Reply Likes
Hey there, sorry for the delay in getting back to you.  There isn't anything on our end that would be getting in the way of your validation, but as it's not something that's a part of our form, we wouldn't be able to be much help.

I did just try to sign up with an invalidly (is that a word?) formatted address and it blocked me, so perhaps you've got it worked out!