Column widths are messing up on mobile

  • 0
  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

When I send a newsletter with 2 columns with the left thinner, and the right wider, it's not responding correctly on mobile. Instead of changing it to a 1 column view, it changes where the left side is wider and the right side is thinner.

The thing that is misleading is it looks great on myemma and on all the preview, but we've had customers reply to our newsletter saying that the format is getting messed up.

Device: Andriod

Photo of Gabrielle

Gabrielle

  • 18 Posts
  • 1 Reply Like

Posted 5 years ago

  • 0
  • 1
Photo of Greg Rathbun

Greg Rathbun, Customer Service Specialist

  • 296 Posts
  • 22 Reply Likes
Hi Gabrielle!

Greg with Emma Support here!

As you've noticed, different email programs will sometimes render emails differently.

I'm not familiar with the email program you're using in the screenshot, but I pulled up your account and did some testing on the email in question.

Testing on my Android phone using the Gmail app, the email appears normally.

Testing in Gmail and Mac Mail on a Mac also shows no issues.

Using a program we have access to called Litmus (used to test HTML emails in a wide variety of email programs), I was still unable to reproduce the issue with the column width. Some mobile email programs did render the email in a single column format as expected (mainly iPhones).

While we may need to chalk it up to a certain email program being quirky, I'd be glad to dig further. Let me know the email program and cell phone make & model you're encountering the issue with. Also let me know if you've encountered the same issue on any other two column emails you've sent. I'll check on your response on Monday.
Photo of Gabrielle

Gabrielle

  • 18 Posts
  • 1 Reply Like
Cell phone is an HTC Desire 610, running Android 4.4.2
And for email I'm using K9 Mail V 5.002
Photo of Greg Rathbun

Greg Rathbun, Customer Service Specialist

  • 296 Posts
  • 22 Reply Likes
HI Gabrielle!

Thanks for the info. Since we've tested your email with the major email clients without problem already, this appears to be a quirk with K9 Mail (possibly just with the version you have installed).

There's a couple ways you might approach this:

One, understand that different email programs may have their own quirks in how they render an HTML email. Since the email looks normal in other programs (including Gmail for Android and the native Android Mail app), you might just accept that it will look different in K9 Mail.

Two, you can try to change your mailing in an attempt to get it to look better in K9 Mail. Try moving content (I.E. a picture or text block) or try a different two column layout and test again. Sometimes doing things like this are enough to improve how a mailing renders in a particular email program.

If you've encountered this quirk in any other email programs, definitely let me know. Otherwise, we'll chalk it up to a quirk of K9 Mail. 

Best regards,
Greg