How can I paste text maintaining text styling?

  • 0
  • 2
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
I was just in one of my campaigns making edits, and I copied something from a line above and pasted it on a line below.  A dialogue box opened and had something to do with pasting with or without styles.  Unfortunately, I just thought it was one of those "quick tip" pop ups and dismissed the box without reading it, however, now styles (i.e. font type, size, links, etc) can't be copied and pasted (when I paste, the text goes back to all the defaults - wrong font, size, color, etc).  Is there a way to change this setting (or get that pop up window back) so that styles will be preserved when copied and pasted?
Photo of City Market, Onion River Co-op

City Market, Onion River Co-op

  • 36 Posts
  • 4 Reply Likes

Posted 3 years ago

  • 0
  • 2
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Official Response
Hey there! Thanks for posting! You can switch that setting back by hovering over a text block, and clicking the Text Pasting option: 



which will bring up this dialogue box: 




Here you can switch how the editor will handle text with styles. For more information, please take a look at our resource center page here

While this will prevent styling from being stripped out of the text, we always recommend starting with unformatted text (either by creating the text in Emma, copying from a plain text editor like editpad.org, or using the clear formatting button) because copying formatted text could potentially bring in additional style tags that, at best, will slow things down, and at worst, cause your email to look strange. In either case, definitely make sure to send tests and tweak your mailing to make sure it looks good. 

Please let me know if you have any questions!