Having trouble adding a link that launches an iOS app

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
  • (Edited)
I would like to add a link in my email that (for iOS devices) launches as iOS app from our company. The link starts with crewalert://scheduleload/%7B%22metadata%22:%7...
With "crewalert" being the name of our app. Normally this works just fine (like in a PDF or a hyperlink in an email), but I've not been able to avoid the emma re-direkt where some wrapping (I think) with "link:" happens automatically. It seems my colon after the appname is lost. I've tried inserting HTML with a normal "
Photo of Jeppesen

Jeppesen

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Adriane Smith

Adriane Smith, Customer Support Specialist

  • 506 Posts
  • 53 Reply Likes
Official Response
Hi Jeppesen!

 I've got two possible solutions for you, both of which will avoid the Emma re-direct linking. 

1. Could you try simply pasting in the entire link address? Most browsers/devices are going to recognize that as a link and then create the link in the inbox. 

2. If you'd like to avoid the display of the link, you could try inserting the link as a personalized URL. To do this, you'd first need to create a new short answer field in your audience, and then add the link in this field for each member of your audience. You can accomplish this by exporting your audience to get them on a spreadsheet, then adding a new column, and pasting in the link address for each record on the spreadsheet. Then you'll import using 'add and update', mapping to your newly created field so that each member now has the link in the field you created. Then you'll be able to follow instructions here on inserting a personalized URL. 

I hope this helps! Please let me know what questions you have!