In agency subs, can't create offset triggers in automation.

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved

I'm attempting to create an automated event that triggers after a subscriber clicks on a link in a particular email.  It would appear that the 'first' event has to happen immediately, which doesn't really make sense in my use case.  My ideal scenario would be for my subscriber to receive my regular newsletter, click on my specific trigger link, and then ... maybe a few days later .. or a week later.. they receive a followup email newsletter based on that original trigger behavior.  

I don't want them to receive an email immediately after clicking.  Right? 

I can see how the 'immediate' thing would work if the trigger event were a sign up to a list - then the subscriber would get a welcome email immediately, and then subsequent triggers would send other messages later down the line.  Is that the only/best way to use automation?
Photo of leedocucinema

leedocucinema

  • 5 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- You can set any email in your automated workflow to send either immediately or delayed. I set up a test link click trigger here and set up the first email in my workflow to send 3 days after the trigger:



Are you seeing that option in your workflow? If not, let me know which sub account you're working in, and I'll take a look!
Photo of leedocucinema

leedocucinema

  • 5 Posts
  • 0 Reply Likes
The subaccount is red cup agency (which is my account).  The workflow I'm wanting to be delayed by say three days or a week is called clicked book.  It seems to be okay with 'immediately' but won't accept 'wait.' 
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
It looks like you're running into a bug that is specific to agency subs. This bug comes into play when trying to offset a trigger in automation. There aren't any workarounds currently, but I will reach back out here as soon as I hear that this bug is resolved. Our development team is already honing in on a potential fix!
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Great news here, our developers have already put a fix in place for this bug! You shouldn't be running into this issue moving forward. Don't hesitate to give us a shout if you see anything like this again. :)
Photo of leedocucinema

leedocucinema

  • 5 Posts
  • 0 Reply Likes
Wonderful!  I am already trying it out.  Hey one more thing - what is happening with my existing 'Trigger" events.  If I leave them alone, and do not bring them into the Automation world, will they continue to function? 
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Any autoresponders built on the old trigger system will continue running as long as you don't cancel them. You'll have to cancel those triggers in order to make any edits to those mailings, and once the trigger is cancelled you won't have the ability to reactivate it. At that point, you would need to recreate that autoresponder using automation.

Our automation feature allows you to make and publish changes to an automated email without having to cancel it! So, if you do need to rebuild those triggers in an automated workflow, you'll only need to do it once. :)