Active number on segment tab and audience grid doesn't update with contact status shift.

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: queue clean up

This has been an ongoing hiccup for a few years now - searches and segments showing odd results. 
For example: 
The tabbed search to see who has signed up in the last 7 days, (and keeping in mind that today is Jan 30, 2015), the results include a member from:
Nov 21, 2102
Nov 9, 2014

I am including a screen capture. 




Similarly, segments (searches) will show incorrect numbers. 
For example, I want to see who has included a USA State, but don't live in the USA. I manually clean that up because there is no way to exclude someone from adding a state if they don't have USA as the country. (That would be a nice to have feature!)

Anyway, that search shows no one ... but says there is one member "active". Odd. 

In this way, most of the segments / searches are off by one or two counts. Not critical .... but you'd expect with a properly maintained database and searches, it would be accurate. 


Photo of Neil van Niekerk

Neil van Niekerk

  • 2 Posts
  • 1 Reply Like

Posted 5 years ago

  • 1
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Neil -- Thanks for including so much detail!

I want to speak to your second question first. I've confirmed that you're running into a known bug there, and I've updated the subject line here to reflect that. This bug sometimes keeps the Active tab from updating when a contact in a segment switches from active to error or opt-out status. I confirmed this by adding myself to that segment, then changing my status to opt-out and running the segment again. It didn't update...as you've shown here. 

I know this is inconvenient, and our development team is working to resolve the issue. I'll post an update here when I hear that this bug is fixed!!

Regarding the sign-up segment, it's important to remember that Emma will always remember a contact's original sign-up or import date. For example, if you imported my address into your audience on Nov. 21, and then I signed up via a sign-up form on Jan. 21, the recent sign-up segment would pull me in based on the criteria, but my contact record would still reflect that original Nov. 21 date.

Does that make sense? In essence, that segment is operating as designed. Let me know if you have any questions!
Photo of Neil van Niekerk

Neil van Niekerk

  • 2 Posts
  • 1 Reply Like
That does make sense. Thank you for responding. 
Photo of E3Live

E3Live

  • 1 Post
  • 0 Reply Likes
Hello Emma Staff - any word on an update to this bug? We are experiencing it as well. Before running into this thread we spent some time trying to troubleshoot, but our number does not refresh. Thanks for any info you have.
Photo of Dispatch Magazines

Dispatch Magazines

  • 11 Posts
  • 2 Reply Likes
Hello, we are having a similar issue - the Active Contacts number has been stuck at the same # for weeks even though we've added subscribers to a Group. Can you provide any insight? 
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hey there -- Are you seeing this in a specific sub account or group? I'd like to take a look and see if I can nudge those numbers. :)
Photo of Dispatch Magazines

Dispatch Magazines

  • 11 Posts
  • 2 Reply Likes
Hi there, sorry for delay. Yes, specifically the sub account Columbus Bride and the Group is the "Primary Newsletter List". Active contacts # is always stuck at 810. 
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hey there -- I copied that entire group over into a new group. This usually pushes those numbers to update and serves as a good workaround while we're working to resolve this bug! To do that, you just open the group, select all contacts and hit copy to select an existing or new group to copy those conacts over to!

Here's how that looks in your Audience grid.



You can delete the original group or just rename the new group. 
Photo of Dispatch Magazines

Dispatch Magazines

  • 11 Posts
  • 2 Reply Likes
Hi Emily, I tried this approach and copied the group again b/c we imported since you made your copy. When I export, the group is there but again the #s are not updating and show 0 contacts. I've cleared my cache, etc. 
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- This bug is resolved! Thanks for you patience as our developers worked to fix this issue. You should now see your audience group counts updating faster and more reliably!