How do I share onto my Facebook Business Page instead of my Personal Page?

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
I posted a month or so ago about my facebook page no longer being linked to my emma account. It turns out, it was asking to post to my personal wall all of a sudden, not the organizational page it once recognized at the share option after sending an email. The advise was to disconnect the profile, and re-connect....but now, the only profile it wants me to connect is my personal profile ( you have to "log in" to facebook at the beginning of the process to get started) . Our current facebook page is a PAGE, not a whole profile, we all login from our individual accounts and have administration access to said what do I do to re-connect our organizational page to the Emma account?
Photo of crossroad campus

crossroad campus

  • 4 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 0
  • 1
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1643 Posts
  • 131 Reply Likes
Official Response
Hey there Crossroad Campus!  

So, when using the Social Sharing option in Emma, it is going to have you log in to your account, and then you'll need to choose the page that you "manage" in order to post to that page.  Here's what that looks like on the Send Success screen (except you won't see my handsome face in my bow tie):

Here you click on the "Your Wall" which pulls up this drop down menu, where you select the organization page that you manage.  

If you're using the Social Share option from the Response Section, you'll click on "adjust your social network settings" at the bottom and then you'll see this:

Here you'll select the business page from the drop down and click "Back to Sharing" 

If it's not showing on that list, then most likely the permissions to allow Emma to post on the page have been revoked in Facebook. 

 This article from our Resource Center talks about giving permissions when you first sign in to Facebook via Emma, but I believe you may need to go into the app settings in Facebook and make sure the Emma Social Connector has permission to "Publish as pages you manage".  

It looks like this in Facebook:

Let me know if you have any more questions!  

- Grey