Facebook link to mailing not working.

  • 5
  • Problem
  • Updated 6 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved

my posting to facebook is not working. Was notified by friend, removed old post and reposted now, but link does not work. HELP - I have 3 classes people need to register for ASAP. Thanks.
Photo of Mary Lydon Krystinak

Mary Lydon Krystinak

  • 3 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 5
Photo of Kyle Floyd

Kyle Floyd, Official Rep

  • 178 Posts
  • 26 Reply Likes
Official Response
Hi Mary! Thanks for reaching out. I am sorry to hear about the struggle you have when linking to your campaign from Facebook. I talked with our developers and it seems you are running into a defect that causes links to break when you post to Facebook from our Send Confirmation Page.

Luckily there is a simple workaround. Login to your account and go to the Response page. From there, locate the name of the mailing you want to share on Facebook and click on that mailing name to view the response details. On the left side of the page you will see a link to the Online version of your mailing, like this:


Click that link to view the online version. Then copy the URL from your address bar and paste that URL to your Facebook post. The mailing thumbnail will still be pulled in and seen on your Facebook page.

We will post an update here once we have fixed the defect which has caused you trouble today.

Please let us know if there is anything we can assist you with.
Photo of Threadart

Threadart

  • 6 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Facebook post error.


Last several Facebook auto posts are not working. No images in Facebook and links are dead. Need help. https://www.facebook.com/Threadart is our Facebook page
Photo of Molly

Molly

  • 5 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Broken Link.


http://e2.ma/webview/8556869/b7b7dd83...
The link Emma created for my campaign mailing is broken, which is a pain and problem. Any help on how to get to work? Thanks!
Photo of Molly

Molly

  • 5 Posts
  • 0 Reply Likes
Not really an easy fix, as you cannot then edit your FB post which already as spread and caused issues.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I apologize for the trouble, Molly. I know it's unsettling that others have seen your Facebook post. Are you able to delete the post from your page and then add a fresh link using Kyle's steps above?
Photo of Molly

Molly

  • 5 Posts
  • 0 Reply Likes
Yes, but again it doesn't help the shares or re-engage the people that bounced
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Have you found that some recipients unexpectedly bounced when you sent the campaign? That would be a separate issue from the Facebook post link, and I'm glad to dig into what caused that, if you'll point me to the campaign on your Response page.
Photo of Stanford University Press

Stanford University Press

  • 7 Posts
  • 2 Reply Likes
Hi Kyle,

Any word on when this will be fixed? The workaround you posted is working fine, though.

Thanks
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Official Response
Hi all,

Updating here that this bug was confirmed to have been fixed last night. :) We appreciate your patience!