FB and Twitter shares NOT Going Out At Specified Date/Time!

  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Didn't hear back from community member

I've schedule a mailing (which goes out when I specified) but the Twitter/FB shares are going out instantly even though I've set the time to a future date/time. What is happening?
Photo of Calamity Chang

Calamity Chang

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- Thanks for letting us know! I'd like to get a few more details so that I can dig in here. You said the share posts immediately, but I just want to clarify that a bit. Is it posting right away or at the time of your scheduled mailing (if that differs from the scheduled post time)? 

Have you tried disconnecting and reconnecting your social accounts to Emma? 

Are you typically scheduling the share to post later on the same day or on a later date? 

Thanks in advance. Eager to dig in here!
Photo of Calamity Chang

Calamity Chang

  • 2 Posts
  • 0 Reply Likes
I gave not tried disconnecting and reconnecting. But it happens when I create a newsletter and schedule it to go out sat, next Monday 9am. The email itself goes out on at the right time/date but the social media ones go out immediately even though I specified Monday 9am for them too.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Thanks for that additional information! I'm digging in here and will let you know what I find.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hey there -- Thanks for your patience as I did some digging on this! I'm not able to replicate this issue, which leaves us with just a few options to explore. First, if you could provide a screencast of your process (and show the post happening at the wrong time), that might help me figure out what's different about your processes so that I can try and duplicate that issue. In the meantime, it might be best to either manually post your mailings to social or to schedule those posts outside of Emma.

One last thing to try would be for me to log into both your Emma and FB accounts to see if I can replicate the issue. This isn't something we usually do, but if you are willing to share those login credentials with me I could take a stab at it! If you want to try that, please save your usernames and passwords for both accounts in a word document and upload it to the document library in your Emma account. I'll log in as you in both accounts and see what I can find! :)