Social posts to Twitter are not happening.

  • 4
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: bug solved

Emma confirms I shared my newsletter/email via my Facebook and Twitter but it's not showing up in either location. My split test went live 5 hours ago, final email sent 1 hour ago. Can't seem to find my shared posts.
Photo of The Selling Agency

The Selling Agency

  • 6 Posts
  • 0 Reply Likes
  • fraggervated

Posted 6 years ago

  • 4
Photo of Emily Foreman

Emily Foreman, Employee

  • 71 Posts
  • 0 Reply Likes
Hi there...sorry to hear you are having issues with the share feature! I'm happy to help figure out what is going on. Could I grab a bit more information from you: what sub account and mailing name are you working in today?

I'll keep my eye out for your reply.
Photo of The Selling Agency

The Selling Agency

  • 6 Posts
  • 0 Reply Likes
Thanks. The agency account and the sub account are The Selling Agency.com
Photo of Emily Foreman

Emily Foreman, Employee

  • 71 Posts
  • 0 Reply Likes
Thank you for the information. I did a little digging around and read that Facebook had an outage yesterday morning. You can read about it here. After taking a peek at your Facebook account, it looks like the campaign eventually posted to your page once Facebook came back online.

Now for the mysterious Twitter share. I'm equally stumped and would like to investigate a bit further. I'll have to get back to you on why Twitter failed to show up on your wall.
Photo of The Selling Agency

The Selling Agency

  • 6 Posts
  • 0 Reply Likes
Hi Emily,

I manually posted the online version yesterday. It never made it via the Emma share button on facebook or twitter.
Photo of Emily Foreman

Emily Foreman, Employee

  • 71 Posts
  • 0 Reply Likes
Hi there, I haven't forgotten about you!

Unfortunately, I am unable to determine why your Twitter post failed to make it to your wall. I looped in a few other support technicians to test and we came up empty handed. Our best guess at what happened is there was an brief blip with the connection either from Emma to Twitter or vise versa, causing the post to fail. If you are noticing more posts are not making it to Facebook or Twitter, try disconnecting your accounts and reconnecting. You can access the post to social options on your Response page. Click on the drop down arrow to the right of any completed mailing, select "post to a social network" and then "adjust your social network settings":



I know this isn't the answer you were hoping for and hopefully this doesn't happen again!
Photo of Love Out Loud

Love Out Loud

  • 14 Posts
  • 2 Reply Likes
I consistently (probably 1 in 3 posts) have the same issue: I send my mailing and then use the Twitter interface within Emma to post a Tweet, and much of the time, the Tweet fails to post to @loveoutloudWS, despite having reconnected it to Emma several times and the logo and Twitter handle appearing onscreen that would seem to confer the connection (see attached). Do I need to simply reset them every....time? week? after closing the browser?
Photo of Love Out Loud

Love Out Loud

  • 14 Posts
  • 2 Reply Likes
Ugh. Still having the same issue. Emily Hollingsworth (or any other Community Engagement Manager), can you help!
Yesterday, after a mailing, the social media screen came up and my twitter ID and artwork displayed as if everything was synched up.
I took about 15 minutes to create a tweet that included everyone's Twitter ID listed in my campaign that I was tweeting about. I didn't even think twice about checking my Twitter profile to be sure it posted (I didn't think I'd need to do that every time).
That was all yesterday....and the post was pretty time sensitive.
I just jumped on my Twitter profile (which I'm just not in the habit of doing) only to notice that once again, the Tweet did not make it from the Emma social media page to my Twitter feed.
Please advise.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Love Out Loud -- So sorry for my delay in responding to your initial comment here. We've definitely had periodic reports of social posts not posting successfully but have had trouble replicating that in the past. Within the last week, we discovered a bug that is causing twitter posts from the send success page to not actually post. With this bug, you will see the success page but the post doesn't actually post...I know, that's not what we want.

We're working on fixing this bug, and I'll be sure to let you know here when it's resolved. In the meantime, I suggest grabbing the webview link for your mailing from the response and posting that directly to twitter. I realize this is not your ideal workflow, and we're eager to get this feature working again for you!
Photo of Love Out Loud

Love Out Loud

  • 14 Posts
  • 2 Reply Likes
Thank you for the reply. Good to know that we should just work directly in Twitter and Facebook for now.
Photo of IIT Chicago Kent College of Law

IIT Chicago Kent College of Law

  • 10 Posts
  • 0 Reply Likes
Hello, I am experiencing this same thing. On the myemma side of things it says I've shared the email I sent out today twice on my twitter but it's been about 20-30 minutes and neither tweet has gone out as far as I can tell. Can you please help? Thanks!
Kelly
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Kelly -- I hopped into my account and shared a mailing to my own Twitter account just to make sure there wasn't something bigger going on here. As far as I know, the share options are working as expected.

Have you tried disconnecting and reconnecting your account in the social connector? Sometimes that can get things moving again! Let me know if that doesn't do the trick.
Photo of IIT Chicago Kent College of Law

IIT Chicago Kent College of Law

  • 10 Posts
  • 0 Reply Likes
Hi Emily - I did try that and share a third time and it still does not. I spoke to a representative this morning when the tweets from yesterday did not show up and he went into my account and is I think still working on figuring out what when wrong since it looks to be working correctly on the myemma end. If you figure anything out I'd love to know. Thanks!
Kelly
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Kelly -- Ok! I'll circle up with Benton and see what we can figure out here. :)
Photo of Hope Clinic For Women

Hope Clinic For Women

  • 1 Post
  • 0 Reply Likes
Hi, same thing happened here. I sent the email yesterday and scheduled the posts on FB/Twitter for this morning at 9am and nothing has happened. It usually works when I share it immediately after sending the email, but maybe the scheduling out caused the error.
Sara
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Sara -- When you scheduled that post, is this the message you added for the tweet? 



I'm trying to rule out a few possibilites for what may have happened here. :)
Photo of Mission Enablers

Mission Enablers

  • 30 Posts
  • 3 Reply Likes
I'm having the same issue. It appears that my newsletters are being posted (according to Emma) but I'm not seeing them on my Facebook page (sometimes they show up, sometimes they don't). Did you figure out what the issue was?

Thanks, 

Heather
Photo of Mission Enablers

Mission Enablers

  • 30 Posts
  • 3 Reply Likes
Emily-

Last week's mailings didn't post anywhere on Facebook (neither my personal account nor the page I manage) though I did schedule it as usual. I'm trying again this week, I'll let you know how it goes...

Thanks,

Heather
(Edited)
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Heather -- Any luck with those later attempts?
Photo of Mission Enablers

Mission Enablers

  • 30 Posts
  • 3 Reply Likes
Emily-

No. Not at all. Every time it's been either posted at the wrong time, on the wrong account or not at all. It was too frustrating so I've given up. Please let me know when the feature is fixed.

Heather
Photo of Bonaparte's Retreat Animal Rescue

Bonaparte's Retreat Animal Rescue

  • 2 Posts
  • 0 Reply Likes
Our campaigns haven't posted to Twitter in months.  Tonight I "scheduled" a campaign to post on FB & Twitter--and NEITHER posted at scheduled time or since.  It's been over two hours since posted time scheduled. Help!
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- I hate to hear that the social posting isn't cooperating with you. There is a known issue with twitter sharing right now that would explain your trouble over the last month or so. As I mentioned above, that is causing those scheduled posts to appear successful but not post at all. We are working to resolve that issue, and I'll be sure to let you know when it's fixed.

I've seen connectivity issues in the past with the Facebook feature, but they're tricky to replicate on our end. I'm happy to take a look, though! Have you since posted manually to Facebook? If so, I'd suggest disconnecting and reconnecting your Facebook account in Emma before trying again next time.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Great news -- the "social posts to twitter are not happening" bug is fixed, thanks to our development team!