Having trouble with personalization fields for date and time.

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Having trouble with personalization fields for date and time. When I import the date is formatted at 4/27/2017 but it shows up as 2017-04-27T00:00:00_1. The Time is formatted at 2:27 PM but shows up as 2017-04-27T14:27:00_1. I already tried reformatting in Excel before the import, as well as changing from short answer to date picker in the personalization setup. The data is exported from SalesForce into Excel, then I import to Emma. When I changed from short answer to date picker the field came in blank for both date and time. For time I changed from short answer to Numeric. Suggestions? Browser: Firefox 52.0.2
Photo of ICAN

ICAN

  • 9 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 0
  • 1
Photo of Greg Rathbun

Greg Rathbun, Customer Service Specialist

  • 296 Posts
  • 22 Reply Likes
Greg with Emma Support here!

I'd recommend using the date picker field when importing dates into Emma.

This will store the month, day, and year within Emma. When you insert it as personalization in a mailing, it will display the month written out. For example 07/27/2015 will display as July 27, 2015.

If the dates don't seem to be coming into Emma, make sure that column is formatted for dates in Excel. Also make sure the year includes 4 digits (a good option would be to format the date as MM/DD/YYYY in Excel, I.E. 07/27/2015).

For times, I'd suggest using a short answer field within Emma. Numeric fields in Emma always include a decimal point and work best when you might want to segment contacts by that number (I.E. I want to segment everyone who had a last purchase price less than $200.00).

Since short answer fields display the data exactly as it is imported, I'd suggested formatting that time column in your spreadsheet for text. This will keep how the time is formatted consistent between your spreadsheet and Emma.

If you have any questions, let me know and I'll be glad to help.