How do I sort contacts by a numerical field, in order?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have a field for all my contacts that's their customer #. I.e., 1, 2, 3, all the way on up past 10,000. But when I sort by number, they aren't sorted in order. The logic is like 3599, then 36, then 360, then 3600, then 3601. Is there any way to sort in a simple ascending order?
Photo of Paul Hughes

Paul Hughes

  • 5 Posts
  • 0 Reply Likes
  • confused

Posted 2 years ago

  • 0
  • 1
Photo of Phillip M

Phillip M, Official Rep

  • 247 Posts
  • 20 Reply Likes
Official Response
Hey Paul, 

After some extensive testing, what I found is that the problem with sorting those numbers in the Emma app is related to formatting in your spread sheet. Excel's default setting is to format those columns as text and that is the way it sorts in Emma. All you need to do is reformat the column in question to a numeric value and remap your contact field in Emma. Once you do that, just re-import that list as an add and update and it should be good. I hope that helps! If you have any additional questions, just let me know. Thanks!