Why are my HTML blocks moving positions when I preview my mailing or test to inbox?

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
When I create a campaign, the formatting shows correctly on my screen, but when I send it, it's different. Meaning that html boxes that I have added are not in the correct spot. I have the html boxes on the right hand side and when sending that campaign, they get moved to the very bottom. Is there a way of knowing what keeps causing this to happen?
Photo of 8z


  • 7 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 0
  • 1
Photo of Katie Watts

Katie Watts, Support Team Manager

  • 422 Posts
  • 66 Reply Likes
Official Response
Good afternoon, 8z!

I hopped into your account and created a copy of your most recently edited mailing on the unsent tab. When I peeked at the preview of that mailing, I saw that the content for two of those HTML blocks in the right column were indeed landing at the very bottom of the mailing.

Although we don't officially support customer-coded HTML, I have a good idea exactly what's causing that to happen in this case! Anytime you're using your own code in an HTML block, you'll want to be sure you're pasting in tabled HTML -- so only code completely contained in a table. The majority of your HTML blocks do contain fully tabled HTML, but those two blocks that aren't staying in place aren't coded that way and are likely breaking the overall table structure of the entire mailing.

Please refine those two blocks so that the code you're pasting in each is completely housed in its own HTML table. I imagine that'll clear the issue right up, but if you have any further trouble with your HTML blocks after you've done that, please give me a shout here and include the exact mailing name for the campaign in which you're working. I'm happy to take another peek!