HTML Disappearing when Using "Create Your Own Code"

  • 4
  • Problem
  • Updated 3 years ago
  • Not a Problem
I am trying to enter my own code using the "Create Your Own Code" option. I've previously done this before with no issues.

Today, when I try to enter my html, about half of the code does not appear to be saving. I pasted the code and verified it was all there (162 lines). But once I click "save," the preview only shows part of the emailer. When I go back into "edit html," only half the code appears (62 lines). I've tried logging out and back in, pasting in the second half of the code, and deleting and recreating the html, but nothing is working.

I am using Google Chrome, which is the browser I've used in the past with no issues. How do I fix this issue? We planned to send this email out mid-morning tomorrow.
Photo of AMS Pictures

AMS Pictures

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 4
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Official Response
I’m wondering if your code contains anything outside our best practices, like body, head, meta, title, html or doctype tags.

If you aren’t finding any of these, I’m glad to take a look, if you’ll save your complete code into a txt file and add it to your document library. Let me know!
Photo of AMS Pictures

AMS Pictures

  • 3 Posts
  • 0 Reply Likes
Thanks for the suggestions, Katie. It seems like there was something wrong in the code causing problems. Rather than look through the whole thing, I just rebuilt it using a previous html that worked (we use a template, so it was easy to plug in). Thanks!
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
That works, too! Glad to hear you’re back in business now. :)
Photo of Innovative Openings

Innovative Openings

  • 2 Posts
  • 0 Reply Likes
Hello... I am having a similar problem to AMS Pictures... have html that disappears when I paste it into the edit html window- I think I have the disallowed tags out... can you help?
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Sure! Would you mind putting your HTML code into a text document and adding it to your document library, and I'll take a look from there?

And just to confirm, you've checked for body, head, meta, title, html or doctype tags? Another idea is to run your code through HTML Tidy to have possible problems pointed out. (We always recommend whomever wrote the code do this, since we aren't coders here!)
Photo of Welch, Gold & Siegel, P.C.

Welch, Gold & Siegel, P.C.

  • 2 Posts
  • 0 Reply Likes
I write a lot of html email and this seems to be overly complicated. I am having the same issue, except none of my code will save. What next steps can I take? I am not using any of the tags you mention above. 

I'm not familiar with your system and using this for a client. 
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Would you mind putting your HTML code into a text document and adding it to your document library? I'll take a look and see if we can isolate the issue.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- It's been a while since your post, so I hope you've had success working with HTML in the editor. I wanted to reach back out here just in case you still need help. Pleae let me know if you need me to take a look at your code.
Photo of Baptists Today

Baptists Today

  • 1 Post
  • 0 Reply Likes
I'm having a similar problem adding the AmazonSmile banner. They provide the html code, but I can't get it to save. Can you help?

I've added the html code to a text doc in my library.
(Edited)
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi there -- I understand you just spoke with my teammate Lauren who was able to take care of this for you. To recap here, the code AmazonSmile was providing to you is a script, which isn't compatible with the editor or email environment.
Photo of April Eve Images

April Eve Images

  • 2 Posts
  • 0 Reply Likes
I could use some help as well. My HTML isn't saving. I will the html code to a text doc in my library. Could someone please look at it? Thank you. 
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hey there, I see that you got hold of Greg and he was able to help out.  

Cheers!