Image in mailing is slow to open/download for recipients.

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
I have built a mailing and when I test send the image within the mailing takes one to two seconds to load after the text, all the recipient sees during this time is a blank image place holder. I have used the smallest possible image size for the mailing I want. 

Is there a way to speed up the image load time or order the image is loaded in?

Do you know of any alternatives or have any other suggestions?

Photo of oneC1TY


  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 0
  • 1
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Official Response
Hello! I took a look at your mailing, and I'm running into the same issue. The main image takes just a second or so longer to load. This is most likely due to the file size of that image, which is around 1.2MB. This is on the large size for an image in a mailing, and any file of that size would take an extra second or two to load. 

To get that image loading as fast as possible, I'd recommend two things. First, you can scale down the image so the width is about 650-700px, which pretty close to the width of your template. Right now, the image is 1064px wide. Second, you could change the file type from a .png to a .jpg. Png files look great and have the best support for transparency, but they're large, relative to jpgs. It looks like this file has some transparency, but if you can find a way to get around this, it might be a good option. 

I would first try scaling the image down to around 700px wide. If that doesn't speed things up, look into resaving as a .jpg. If neither of those suggestions work, let me know and I'll take another look!

(Heads up, I edited this moments after saving, since I caught the transparency in the image, so it might be different than the notification you got in the inbox. That's all!)