Image Library Not Loading

  • 1
  • Problem
  • Updated 7 months ago
On Chrome & Edge our image library is not loading.

We have tried accessing the image library on 2 different computers and browsers and we are still seeing the issue.

Within an email template, we click an image placeholder then select "Choose Another Image" the Library window comes up but stays with a "Loading ..." screen indefinitely. We have waited as long as 5 minutes and the library did not load still.
Photo of Montia


  • 1 Post
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Anthony Miranda

Anthony Miranda, Customer Support Specialist

  • 122 Posts
  • 15 Reply Likes
Hi there!

Sorry to hear about that experience you're having. Let's see if we can figure out what is causing that. 

I jumped in and was able to load your image library while in a campaign without any issue. That tells me there isn't anything wrong with the account or any of those image. You've already taken some great troubleshooting steps and tried a couple computers and a couple browsers. Since that didn't help, we want to shift our attention to the network. I'm assuming both of the computers you tried this on were using the same network. Is that correct?

It's possible that there is some type of firewall or other security setting that is stopping us from access that particular data. Can you try logging into Emma on a completely different network and accessing that image library from a campaign? It should only take a minute to confirm whether or not the experience is different and it would be very helpful in determining what the next step should be.

I'll keep an eye open for your reply!