Image library saves image even if "Save to library" remains unchecked

  • 1
  • Problem
  • Updated 1 week ago
  • Acknowledged
Hi Emma!

I recently started working with your service through a new job and the staff are complaining about issues with the image library. Files are getting saved to it even when the box to do so remains unchecked, this is happening in all our browsers and operating systems. This has caused to media library to swell enormously (we send campaigns almost every day so you can imagine how it adds up). It takes forever to load because it's so big and is slowing down our workflow.

Is there any solution to this? Is there a way to bulk remove old assets? Thanks very much for any support or help you can provide!

Cheers,
Margot
Photo of Bitch: Feminist Response to Pop Culture

Posted 2 weeks ago

  • 1
Photo of Zach Sharpe

Zach Sharpe, Employee

  • 240 Posts
  • 24 Reply Likes
Hi Margot, I can certainly understand how this would cause your image library to become unwieldy very quickly!

I did some testing in my own account with this and I'm not experiencing the same behavior.

The things I tried here were:

- Drag in an image to an image block in a campaign
- Selected 'upload' , chose the image.

In both cases I checked image library after and they were not included.

You can also try clearing your cache & cookies if you are doing the 2 options above and still see assets save.

For clearing out your image library there is not a bulk method to delete these in the account, only singularly. I will certainly pass this along as a suggestion however as I can see how that might be very helpful!

I hope this helps point you in the right direction and let me know if I can help answer any additional questions!

Thanks

Zach