Image size too large or wrong file format.

  • 0
  • 3
  • Question
  • Updated 2 years ago
  • Answered
Every time I try to upload an image I get this error:

"Image could not be uploaded

Please make sure the file is under 25MB.

Files should be PNG, GIF, JPG, or JPEG.

Invalid file type. ()"

I've checked the image multiple times. The file size is well under 25MB and was saved in the specified formats. I've even tried different formats that you accept. I logged out and logged back in. I restarted my computer and still, I'm getting this error. If this is an ongoing issue please let me know when it has been resolved.
Thank you.

System info:
Mackbook Pro / Sierra OS / Chrome Browser
Photo of DAS Audio

DAS Audio

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 0
  • 3
Photo of Phillip M

Phillip M, Official Rep

  • 247 Posts
  • 20 Reply Likes
Phillip from Emma Support here! This sounds like it may be a caching issue. Please clear the cache and cookies in your browser or since you are using Google Chrome just login to Emma in an 'Incognito Window'. I hope this helps, but just let me know if this troubleshoot doesn't work for you. - Thanks!
Photo of JonathanM


  • 1 Post
  • 0 Reply Likes
I am receiving this same error. I just tried again in incognito mode and received the same error. I can't create my campaign at this time. Any other suggestions?
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Just to be clear, does your image fit these specifications:

Format: JPG, PNG, GIF

Max file size: 25MB (Recommended Size 1MB)

Image size: 1280px width

Color Profile: RGB (not CMYK)

Resolution: 72dpi

For GIFs: No more than 10 frames recommended

If one format is not working, perhaps try a different format to see if that acts any differently.  

- G
Photo of DAS Audio

DAS Audio

  • 2 Posts
  • 0 Reply Likes
My final solution after verifying the format (tried all 3) and the file size was:
Open in Preview (MAC)
File > Export > JPEG
Then I used the new file without any issues. I'm not sure if its a bug or if something is happening in Photoshop when saving. I hope this helps.