Include commas or decimals in numeric contact field

  • 1
  • Idea
  • Updated 3 years ago
  • Not Planned
  • (Edited)
How can I change a field option to include commas but not the decimal? I have a spreadsheet that have large numbers but the short answer removes the thousandth commas (Example: 34,322 changes to 34322)

Note: This conversation was created from a reply on: Why does Emma append a .0 (dot zero) to some of the ZIP codes on my audience list....
Photo of Kiko

Kiko

  • 6 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Kiko

Kiko

  • 6 Posts
  • 1 Reply Like
Is it something to do with how the list is imported?
I just noticed that if I manually put in the information, it keeps the comma.
But if I import a list, it automatically removes the comma.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Kiko -- Good question! I'd like to dig in on this to see if changing the format of the data in the spreadsheet might impact how it's imported to that short answer field. Could you upload your file to the documents library on the campaigns page of your account? You're working in the Milliken sub account, correct?

I can download the file from there and take a look! Thanks. :)
Photo of Kiko

Kiko

  • 6 Posts
  • 1 Reply Like
Hi Emily, Thanks for getting back to me. I figured it out (i was under a tight turnaround period)
I had to change my excel spreadsheet so the cells would be formatted as text (vs. numeric, which would automatically put in the comma)

The only way I found that would work was to select the column, format cells to numeric (1,000 comma and no decimal places) and Copy. Then format the cells to Text and Paste special as text.

If there was a way for MyEmma to give the option to have 1,000 separator, that would be great! I had over 50 lists to upload with over 100K contact to short through, so it was quite time consuming :/

Thanks for your response!
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Hi Kiko! I see that your field is set up as a short-answer field, which is what I'd advise so that it will accept a character like a comma; a numeric field wouldn't accept the comma.

Since you're using a short-answer field, you will want your data to be formatted as Text instead of as Numeric, and it sounds like you figured that out. I think what you're wanting is a numeric field that allows a comma or decimal; is that right? I'm hoping we'll eventually have numeric fields that allow you to choose whether you want commas or not and how many decimals should be included, if any. We aren't there yet, so hearing from Emma users like you who want this is helpful to get us there!
Photo of Azhar Chhipa

Azhar Chhipa

  • 1 Post
  • 0 Reply Likes
Wht is the full meaning of k ?
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Hi Azhar! K means x 1,000, so 100K means 100,000.