Can't import CSV file with special characters

  • 6
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved

I am trying to import a .csv file, but it is telling me there is something wrong with the formatting of my document. I have imported lists many times in the past through MyEmma, but have never had this error pop up before. My list is considerably longer than past lists, however. Is there a limit to the amount of contacts you can load at once?

Trish
Photo of Tahoe Yoga & Wellness Center

Tahoe Yoga & Wellness Center

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 6
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I'm so sorry to hear you're frustrated, Trish! Would you mind saving your file as .xls or .xlsx instead and importing that? There's a bug in our platform that prevents .csv files with special characters from importing. Rather than combing through the file to find the special character, saving as a different file type is a simpler solution.

Keep me posted with the result!
Photo of Tahoe Yoga & Wellness Center

Tahoe Yoga & Wellness Center

  • 2 Posts
  • 0 Reply Likes
That worked!!! For some reason I always thought .csv was preferred, and that .xls wouldn't even worked. This was great though. Thank you so much for the quick feedback!

Trish
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Glad to hear it, Trish!

I'm updating this topic so we can track that bug.
Photo of Dover Downs Hotel & Casino

Dover Downs Hotel & Casino

  • 26 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Error while importing a csv file.


I'm getting an error while importing a csv file. I've uploaded other csv files with no issue. This one is giving me trouble. Any ideas what might be causing the issue?
Photo of Roxanne Davis

Roxanne Davis

  • 35 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Import will not work.


I need to import a CSV file. It has only three columns and there are no blank rows.

Every time I try to upload it I receive the pink bar at the top that says there's a problem with the file.

I have copied the text and done a "paste special > text only" into a brand new file, saving it as a brand new CSV file. Still getting the pink bar.

HELP!
Photo of Roxanne Davis

Roxanne Davis

  • 35 Posts
  • 0 Reply Likes
Perfect - thanks!
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
It's my pleasure!
Photo of Ruminate Magazine

Ruminate Magazine

  • 5 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Hi there, I have been performing a much needed update on our e-mail list and for some reason the imports have started failing.


Hi there, I have been performing a much needed update on our e-mail list and for some reason the imports have started failing.  I'm using the same template I used for previous updates today. We have several scattered email lists and maybe I've triggered some sort of limit as to how many times you can perform an update?   Thanks for your help!
Photo of Katie Herzig

Katie Herzig

  • 3 Posts
  • 0 Reply Likes
Hi guys, i am getting the "There seems to be something wrong with the formatting of your file." error when importing my CSV with a lot of names on it. I tried saving it out as MS-DOS formatted CSV and Windows-formatted CSV as well, both giving me the same error.

As I mentioned in another bug, importing the list as an XLS is not an option because your system keeps adding a .0 at the end of all the zip codes. 

This is an urgent import, please advise!
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Katie, I’m so sorry you’re hitting this limitation. The way the CSV bug works is that any special character will kick an error. How about this?: Import your XLS file without the zip code column just for the time-being. This will get all of your content into your account.

Then, go back to your file and delete all columns except for the email address and zip code columns, and import this as a CSV. Hopefully the special character is not in either of these columns and will let you import, but please let me know if you’re still getting the error, and I can take a look at the file.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Good morning, all! I’m happy to share that this bug has been fixed. :)