Lightbox Edits Aren't Generating on Website

  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: queue clean up

I'm using Emma's lightbox form on a Shopify website. When I "X" out the lightbox it continues to pop on on every page I visit. I altered the location and timing within the form and reinserted the code within Shopify but the lightbox edits aren't activating on the webstie. I even created a new form and deleted the old one and still no change. Thoughts on how to get the lightbox to behave? 
Photo of Digital FX

Digital FX

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey there, thanks for posting! I find that when making edits to lightbox forms, you need to clear cache and cookies each time you make changes and click save. The site could be referencing an old version of that form that doesn't have your updated settings. 

Clearing cache and cookies this frequently can be tedious, so another option would be to open a new private or incognito browsing window each time you head to the site to check the lightbox form. 

Try one of those options and see if it works! If not, I'm happy to take a deeper look!
Photo of Digital FX

Digital FX

  • 2 Posts
  • 0 Reply Likes
Ah ha! It's working now. Thanks for your help!
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Paul,

I noticed the new LIGHTBOX Signup window does not work on SECURE sites (HTTPS). Only on the HTTP version... is there a secure version?

Thx
DJ
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey DJ, We wouldn't expect any issues with HTTPS sites, so it could be either a problem with how the form is set up within Emma, a conflict with your particular site, or both. 

I just took a look at your Lightbox form settings and your website. and after viewing the source code for https://www.packagefromsanta.com/, I didn't see the code from the last step of the Lightbox setup process. Make sure that code is immediately above the closing body tag, </body>, and be sure to reset your browser's cookies before trying it again. 

If adding that code doesn't fix it, or if I'm just looking at the wrong website, let me know! Please include the website that you're trying to add the form to, and the name of the sub-account you're using to build the form. I'll take another look!
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Paul,

Thanks for reply...

Sorry our test page for this is actually:

https://www.packagefromsanta.com/tests/TestOptInLightning4.html

Notice it does not work with the "HTTPS"... but take away the "S" and it works.... ?

Thx
Dale
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Paul,

Is there a way to create a 'custom' sign up form? It looks like the editor for 'classic signup forms' is a template.

Thx
Dale
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Paul, you there? :)
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey Dale, so sorry for going dark! After some testing, I'm stumped on the HTTPS issue, so I've passed this along to our developers to see if we can dig a little deeper. It looks like your observation is exactly right, and the Lightbox form is set up correctly, so we expect to see the Lightbox on the https site as well as the http. I'll be out of the office next week, but someone from our support team will give you the latest as soon as our developers find out a little more about what's going on. 

On the topic of custom forms, you can create a custom form using our open API, but our Classic signup forms are a little more sparse. You might be able to use a Javascript form and style it on your own site, but we don't have any way to add images or styling aside from the image at the top. 

You'll hear back from us here in the next few business days, but please let me know if you have questions in the meantime!
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
No worries on delay. Thanks for getting back... just need to get it working, eventually. :)

Have a great 4th.

-Dale
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Dale -- Emily here, jumping in for Paul while he's out of the office. Could you delete the current lightbox script from your test page so we can take a fresh look? Let me know when that's done, and we'll jump back into this!
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Emily,

hi... sure.

we removed the script. and renamed the page.

https://www.packagefromsanta.com/tests/TestOptInLightning5.html

Keep in mind, that this is literally a test page... with nothing on it.

Thanks,
Dale
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Thanks - I'll reach out when I know more!
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Thx! :)
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Emily, any luck with a fix?

Thx
dale
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Still doing some testing on our end. I hope to have an update for you today or tomorrow!
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi again! We released some work not too long ago to improve how the forms work with secure sites, but it looks like that release isn't working as expected. While we work to get this going again, you'll need to point visitors toward the http version of your site as opposed to the https. 
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Emily,

Thanks for the update... but we HAVE TO point our traffic to HTTPS... it's secure, and google is favoring secure sites. :(

Any timeline on a fix?

thx
Dale
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Dale -- I don't have a timeline on this, and from what I understand, it's not a quick fix. So, it might take some time before we can get this change implemented. Another workaround would be to use a custom form linked to your Emma account through our open API until this change is in place.
Photo of PackageFromSanta.com

PackageFromSanta.com

  • 10 Posts
  • 1 Reply Like
Gotcha. Thanks! :)
dale