Enabling "Do not track" browser flag interferes with lightbox timing rules

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
  • (Edited)
The lightbox form has a "How Often" timing delay of every 5 days. However, even after it's dismissed (which should dismiss it for 5 days?) it continues to show up to anyone viewing the site. Example URL (there is a 30 second delay to show the lightbox): http://www.lipscomb.edu/news/archive/detail/101/29847


Photo of Kyle Gregory | Lipscomb University

Kyle Gregory | Lipscomb University, Champion

  • 99 Posts
  • 69 Reply Likes

Posted 3 years ago

  • 1
Photo of Damian Gatta

Damian Gatta, Official Rep

  • 342 Posts
  • 43 Reply Likes
Hi Kyle, 

I hopped over to http://www.lipscomb.edu/news/archive/detail/101/29847 and the Lightbox form displayed after 30 seconds.  I closed the form and then shut down the browser tab.  I went back to the site and the form did not show again after 30 seconds.  In your experience when the form shows up again before the 5 days, are you using the same browser you originally were using when you first saw the form display?  If yes, were the cache and cookies cleared in the browser from the time you first viewed the form?

Also, can you let me know which sub-account the form was created in so that I can take a peek?  

I'll be on the lookout for your reply!
Photo of Kyle Gregory | Lipscomb University

Kyle Gregory | Lipscomb University, Champion

  • 99 Posts
  • 69 Reply Likes
Same browser. Chrome for Mac 46.0.2490.8646.
Account is 27120.

I've had the same reports from other users, they dismiss the dialog only to have it open again and again. I just got back to my desk and tried it again and it's not happening now. Wondering if there was a bug the last few days, maybe?
Photo of Damian Gatta

Damian Gatta, Official Rep

  • 342 Posts
  • 43 Reply Likes
Hi Kyle, 

I have not heard of any reports with Lightbox forms but it seems to be working as expected.  Keep an eye on it and definitely give me a shout if you see anything that is not working properly so that we can take a look!
Photo of Ashley

Ashley

  • 68 Posts
  • 30 Reply Likes
Hey Kyle, we were having lightbox issues today as well so I decided to check yours out and I'm not able to recreate the issue you're having. Just an update from an outside source; hope that means you got it resolved.
Photo of Kyle Gregory | Lipscomb University

Kyle Gregory | Lipscomb University, Champion

  • 99 Posts
  • 69 Reply Likes
Official Response
Just an FYI in case anyone else views this thread. The problem, in this case, stems from having the "Do Not Track" flag enabled on your browser. If this is the case, the cookie is never set to prevent the lightbox from appearing or following your delay settings. Note DNT is enabled by default on Internet Explorer 10, however other browsers that support it the user must explicitly set it. Hope that helps someone else.