Lightbox signup forms won't stop popping up and isn't following the "rules" we set for it

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

We have two lightbox forms, one for each of our websites (separate MyEmma account for each one).

On both websites we're receiving complaints from users that the lightbox forms just won't keep popping up on multiple pages, despite the settings to only show once. The complaints are inconsistent in terms of the platforms—it's happening to some PC users, some Mac users, some users of Chrome/Safari/IE/Edge—but there's no overall thread that links them together. It seems fine when I test it, but I'm sure the users aren't making this up. 

The websites are on entirely different platforms, too. If it were just one of the websites then I'd be inclined to think it was "just a coding issue", but because it's on both I think it may be related to the lightboxes themselves.

Has anyone else had issues and have you been able to resolve them?

I'm at the point of deactivating the whole thing, and even will even consider going to another provider entirely if it can't get resolved soon :(
Photo of Roxanne Davis

Roxanne Davis

  • 35 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 0
  • 1
Photo of Phillip M

Phillip M, Official Rep

  • 247 Posts
  • 20 Reply Likes
Hi Roxanne,

Phillip from Emma Support here! I am going to email you to request a bit more information on this and I'll speak with you soon. Thanks!
Photo of Phillip M

Phillip M, Official Rep

  • 247 Posts
  • 20 Reply Likes
Roxanne and I were able to get this resolved through email correspondence as some of the info I needed was unique to her account. The issue here appeared to be 
related to cache and cookies. Perhaps these visitors cleared their cache and cookies since their last visit to the site which will cause the lightbox to reappear. Another scenario is the lightbox form keeps reappearing when it's closed by hitting the X and then the screen is refreshed. Another possible culprit is the cache and cookie settings within a particular browser. If they do not have cookies enabled, then the lightbox may continue to appear. I hope this helps!