Getting logged out of my account early and often

  • 14
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved!

Starting yesterday(ish) I noticed that I am being automatically logged out much faster than I used to. I would guess I am logged out after 10-15 min of no activity. I was working on an email and got a phone call. When I went back I got a message that it timed out. So I logged back in and landed on a screen that was nothing but code. There were no links, navigation, nothing. So I had to manually open the Emma URL to log in again.

Note: This conversation was created from a reply on: Increase one-hour logout window.
Photo of Chinook Medical Gear

Chinook Medical Gear

  • 36 Posts
  • 5 Reply Likes

Posted 4 years ago

  • 14
Photo of Chinook Medical Gear

Chinook Medical Gear

  • 36 Posts
  • 5 Reply Likes
I was also logged out after less than 20 min.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Thanks for the info! Can you tell me anything about the circumstances of getting logged out? Were you in the middle of working, or was Emma in the background? Do you remember what you were doing at the time? 
Photo of Denise Peeler

Denise Peeler

  • 34 Posts
  • 2 Reply Likes
I am still getting logged out. I was actively working on a segment, and could not save it. When I went back to the Audience tab it went to the login screen. Another person on my account reported similar events yesterday when working on a campaign. He only uses Emma about every-other-month. 
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey Denise, thanks for letting me know. This might be related to an issue that looks similar, but is actually due to a bug in our segment tool. We're finding that if you let a session time out, you can get logged out when trying to make a segment after you log back in. We're aware of that bug, and we're in the process of getting it fixed. I'll reach out directly after we've got that fixed. 

In the meantime, you can prevent this by clearing the cache and cookies in your browser, and by logging out at the end of sessions. Let me know if you have any more questions!
Photo of Distinctly Montana-

Distinctly Montana-

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Why are my changes when creating a template NOT being saved?.

This has happened to me so many times... where I am working on an e-mail template and it says it is constantly 'saved' and then Emma will randomly log me out and then make me sign back in. When I go back to my templates, none of my prior work/edits are saved and it basically brings me back to the beginning. Anyone else? This is so frustrating!
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
I'm sorry that's been so frustrating! We're working on getting this resolved, and we're hoping to gather as much information on the systems that are experiencing the early logouts as we can. Take a look at my second official post, and let me know the answers to those questions. It will be a big help towards getting the bottom of this bug! Thanks for your help in advance!
Photo of Cynthia

Cynthia

  • 123 Posts
  • 29 Reply Likes
This keeps happening to me as well - very annoying. I take a phone call, or respond to an email, or answer a question, then turn back to Emma and find out that I have been logged out even though its only about 10 minutes. It usually happens when I'm in the middle of editing an email. No sub account; using Chrome Version 37.0.2062.124 m (Emma works very slow in Firefox); don't have Emma open in multiple tabs; receive same screen as others above; username is cbraman@bookeseminars.com.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Thanks for the information Cynthia! I'll let our developers know, and I'll inform everyone on this thread when the bug is fixed. 
Photo of Community Partners of Dallas

Community Partners of Dallas

  • 1 Post
  • 0 Reply Likes

This is still happening to me in Firefox. I get logged out all the time either after about 5 minutes of inactivity or in the middle of writing a sentence. No sub acct; using Firefox 38.0 on Windows 7; I don't have emma open on multiple tabs; receiving the same HTML screen as above; Logging in through the gray timeout page never works, so I always have to relaunch emma; username is Communitypartnersofd.


As a note, in the time I've been writing this I got logged out again.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Thanks so much for that information. I'll keep you updated!
Photo of Florence-Lauderdale Public Library

Florence-Lauderdale Public Library

  • 25 Posts
  • 1 Reply Like
I'm still getting logged out after a few minutes of inactivity while editing a campaign, as well. Here is a screenshot.

Photo of Creative Outreach Ministries

Creative Outreach Ministries

  • 1 Post
  • 0 Reply Likes
Same here... I get logged out probably every 5-10 minutes
1. What sub-account are you working in? Did you notice this happening in other sub-accounts as well?

N/A

2. What browser (and version) are you using? You can go to www.aboutmybrowser.com to quickly get that information.

Chrome, Version 43.0.2357.81 (64-bit), Mac OSX Yosemite 10.10.3

3. What part of the Emma application are you working in when you experience that automatic logout trouble?

Campaigns

4. What were you doing when you got logged out? 

Working on a campaign and went to find photos for 5 mins. Came back and tried to type some text and was notified I had been logged out

5. Do you have Emma open in multiple tabs on your browser?

No

6. Could you take a screenshot of the "you've been logged out" screen?



7. Last of all, what username are you logging in with?

media@creativeoutreach.com
Photo of Handyman Soaps

Handyman Soaps

  • 17 Posts
  • 2 Reply Likes
This reply was created from a merged topic originally titled How do I increase the automatic logout due to inactivity?.

Being logged out after only 10 minutes of inactivity is frustrating. Is there a way to make that time setting longer? At least an hour, say?? I go to look for a photo, and it may take a while, and I'm logged out.

Thanks.

I use Google Chrome browser v. 43.0.2357.81
Photo of Paris Group Realty

Paris Group Realty

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled how can I stop emma from loggin out so quickly?.

We work between several sites/windows and it seems I have to re-log into emma every 15 minutes. Is there a way to change this? I checked in settings but perhaps overlooked it?
Photo of Florence-Lauderdale Public Library

Florence-Lauderdale Public Library

  • 25 Posts
  • 1 Reply Like
I am now being logged out repeatedly while trying to create segments and groups. I haven't even been inactive for more than a minute. Is there any ETA on having these problems fixed? I really, really love Emma (a coworker and I even went to the conference and pre-conference), but my patience is starting to stretch a little thin, as you can probably understand.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey there, this sounds like a related, but slightly different bug. If you your session times out without clicking the logout option from the tools menu, segments can start to misbehave. For segments in particular, we have found that clicking the logout button, then clearing your browser’s cache and cookies will get segments working properly again. Try those steps, and let me know if that helps!

I'm so sorry you're running into these logout issues. I completely understand that your patience is running thin, as this has ben especially frustrating for users. We don’t have an ETA, but it has been one of the more reported bugs as of late, and we’re digging in to find a fix. I’ll let everyone know when we’ve got a fix out; hopefully it won’t be too much longer. 
Photo of Florence-Lauderdale Public Library

Florence-Lauderdale Public Library

  • 25 Posts
  • 1 Reply Like
Thank you for the tip! I will give that a try next time I'm using segments, and I'll let you know.
Photo of NJPSA/FEA

NJPSA/FEA

  • 108 Posts
  • 6 Reply Likes
Me too!
Photo of Tina

Tina

  • 8 Posts
  • 3 Reply Likes
I am becoming very frustrated and feel that this problem has gone on for quite some time.  What was once a very useful program for me is now just a source of frustration.  I took a short phone call today and was logged off.  Not to mention the amount of time it takes Emma to "think" about the command I just gave.  By command, I simply mean pressing one of the options given.  It either takes so much time that I start working on something else or I get the "oops" message.
Photo of NJPSA/FEA

NJPSA/FEA

  • 108 Posts
  • 6 Reply Likes
I hate the "oops" message!
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Official Response
Hey folks, just a quick update. We haven't forgotten about this issue, and we're still working to get it fixed. It's been especially hard to pin down a fix since we're unable to reproduce it consistently. That's not to say that we don't believe it's a real issue -- we've had numerous reports, and it's a bug in our system that we're actively tracking. 

Being unable to reproduce does make it harder to find a fix, however, since we can't easily find the source of the problem. Here's a (rough) analogy: imagine a smoke alarm with a dying battery. It chirps once every 30 seconds to let you know it's dying. If you’re like me, and have a few smoke alarms in your house, you spend those 30 seconds looking around trying to figure out what just beeped. Then when it does, you move towards where you think the sound came from, and wait again. Then again: you hear it, move, and wait. (And, if you’re still like me, you were wrong the first six times, and it was actually the carbon monoxide detector that rolled behind the fridge.) If the smoke alarm would just beep consistently, it would take 15 seconds to find it, and another 15 seconds to replace the battery. But since you spend so much time hunting down the beeping sound, it takes longer. 

In the case of bugs, intermittent bugs that affect some users but not others are especially difficult to track down, because we spend so much time finding the root cause of the bug. Usually intermittent issues have to do with some kind of interaction between our application and more local factors, like browser, computer or network, which is why we’ve asked for so much information from users who are running into this bug. That information has been helpful so far, so if you’re still getting logged out while in the middle of editing, please answer the questions I posted earlier in this thread, and we’ll take that into account. 

Please know that we’re hearing you, and we’re digging in. It’s clearly a frustrating bug that’s having a direct, negative impact on your experience using Emma, and we’re working hard to track down a fix so that experience will improve. It would still be helpful if you would answer those questions I asked earlier so we can have that information on hand. Also, if you’re one of the users who has experienced that bug, but have since not been logged out early, please let me know! You might have some information that can be helpful to everyone.
Photo of Cornerstone

Cornerstone

  • 16 Posts
  • 1 Reply Like
I get logged out all the now time while composing a campaign email.  If I don't actively type something or change something within a certain amount of time (never timed it though) it says my session has expired.  I use Firefox and it's the only tab open at the time.  I just figured you changed your inactivity / session expiration time...until I saw this post.  I have to do other things while creating a campaign (find links, create images, wait for updated info, etc.) and every single time I get logged out.  Three or four times I received the page full of code.
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
This log-out issue is also happening to me too and seems to align with what others have seen -- it's about five minutes before it logs me out, and it seems to have started a few months ago. I'll also add another weird little issue -- maybe related, maybe not -- where functionality, also after 5-10 minutes of using MyEmma, my response time, such as for saves, selecting text, doing most any kind of task within MyEmma, slows down -- the cursor/the system just takes a few seconds to respond -- I'll select text but it'll take a few seconds before the text tools become active so I can use them. It gets annoying to the point that I have to close the browser tab and re-open MyEmma to then be able to have it run 'at full speed" again -- for 5-10 minutes until it slows dpown again. This happens VERY consistently and is not something I see in my computer otherwise or with other browser-based sites or functions....
Photo of AGC of Washington

AGC of Washington

  • 91 Posts
  • 6 Reply Likes
I don't know if this is related or not, but this all seems to be occurring at the same time. Every time I "save" a campaign, the screen refreshes and has a black bar across it, as shown in this screenshot...



It doesn't harm anything and goes away when I either refresh or scroll up or down, away from this part of the page. But it's very weird. Still using Firefox as I have been for a couple of years...
Photo of Ted Hogan

Ted Hogan, Champion

  • 145 Posts
  • 83 Reply Likes
I don't wish to be guilty of piling on here, but I have been seeing the log out "due to inactivity" prompt much more frequently over the last few weeks. Sometimes I have been on the  response screen for a recent mailing  and watching the response numbers update, but if I try to refresh the page, I am logged out. Normally I just login again.

Yesterday, there was something new. I was creating a new mail in the drag-and-drop editor when I attempted to upload a photo from my local machine. To my surprise and frustration, the prompt popped up telling me I had been logged out due to inactivity -- while I was actively working in the editor. The autosave had recorded my most recent changes before I was logged out, so I did not lose any work, but I did lose some time while I was on a tight deadline.

FWIW, I'm running a Dell tower with Win7 and the latest version of the Google Chrome browser, but I have also seen the timeout issue on other occasions on my Macbook Air, OSX  Yosemite 10.10.3, and Chrome.

My 2-centavos worth. It's a mystery.
(Edited)
Photo of Cynthia

Cynthia

  • 123 Posts
  • 29 Reply Likes
The log-out thing has been happening to me this morning. I just launched an email and when checking the response and seeing who bounced, it logs me out. Also, for some reason the Click View is not showing the response bubbles. Campaign: Handbooks June Email
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Official Response
Hi friends -- We're officially calling this issue resolved! Please give us a shout here if you're seeing something different. Thanks, as always, for your patience as we worked to resolve this bug.