manage_url and optin_confirm_url -- 500 error

  • 1
  • Problem
  • Updated 5 years ago
  • Not a Problem
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved

The 'manage_url' and 'optin_confirm_url' links are not working in our emails any more. Both the URLs I manually added to the body copy, and the URLs that are programmed into the template.

Here's our welcome email: https://t.e2ma.net/webview/s4ls5i/c504c35153e21b10e7df01ea849ec969

When you click links to update profile or confirm opt-in, there's a 500 error
Photo of Matt Olsen

Matt Olsen, Champion

  • 117 Posts
  • 43 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hey Matt! I'm digging into this and will let you know what I find. 

I did notice that in the "Newsletter Welcome Auto Send" mailing, you're using the Welcome template, which I don't see in your My Templates section anymore. Could it have been deleted and this mailing copied over from another sent mailing or draft? Or am I looking at the wrong mailing, perhaps?

Thanks!
Photo of Matt Olsen

Matt Olsen, Champion

  • 117 Posts
  • 43 Reply Likes
The template was just updated with a different logo version. It's called Welcome [new logo].
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Matt -- I'm sorry for my delay in getting back to you here. The issue here seems to be with the sign-up form that all of those links are directing to. I'm going to dig into that a little further!

For now, you can select a different sign-up form to send with that mailing on the review and send page:



I tested this using your "new signup form" and those links worked! I'll reach out here when I know more about why your other sign-up form isn't working.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Matt -- Can you tell me if you're still able to produce that 500 error when clicking the manage or confirm links in your email when sending with the Manage Preferences sign-up form? My colleague was doing some more advanced testing for me and was able to click through those links successfully. 

Thanks in advance!
Photo of Matt Olsen

Matt Olsen, Champion

  • 117 Posts
  • 43 Reply Likes
It seems to be working fine now. Thanks!
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Great! Thanks for your patience on this.