Missing the "Show Templates" link

  • 2
  • Problem
  • Updated 4 years ago
  • Not a Problem
We are missing the "Show Templates" link in the top right hand corner of the Campaigns screen. It seems to be related to the template type. The two that are affected are our Member Email Templates and Participant Email Templates. When these are selected we cannot switch the template. (We used to be able to.)

This is affecting all our sub-accounts. 

We typically use Chrome and see the issue across browsers and platforms (Macs and PCs) 

We'd like the Show Templates link turned back on please, if possible. 




Photo of Liz Stephenson

Liz Stephenson

  • 35 Posts
  • 16 Reply Likes

Posted 4 years ago

  • 2
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Official Response
Hi Liz -- We recently made a change in the editor to hide the "show templates" link when working in a template that does not have a flexible layout tag. We made this change so that users don't lose any content trying to switch from a template without a flexible area to a layout with a flexible area. The two templates you mentioned were built with no flexible area, which is why your users no longer see that show templates link. 

If you're users are finding that they often need to switch back and forth between templates, particularly from these template that do not have a flexible area, I'd love to hear more about their process. Thanks!
Photo of Liz Stephenson

Liz Stephenson

  • 35 Posts
  • 16 Reply Likes
Hi Emily - thanks for the information.

Can you tell me what a "flexible layout tag" is? 

Our designer built our templates, so I am not sure how she may have built them differently.

Thanks. 
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Sure thing! The flexible layout tag is an HTML tag added to the template that creates a space where you can drag in, edit and rearrange content blocks using the drag and drop editor. You'll notice in the two templates you mentioned above that there is no space in the body of the mailing to drag in new content blocks. The content elements are hardcoded into the template, rather then flexible.

This is a design preference that allows more agency control over the mailings your sub accounts send out. If it's not necessary, your designer could add that flexible layout tag to the template code to provide a flexible area for the template. Keep in mind that when there is a flexible region in a template, that area will populate with default content blocks and placeholder text that your subs can either replace or remove.
Photo of Liz Stephenson

Liz Stephenson

  • 35 Posts
  • 16 Reply Likes
Thanks Emily - that is a good suggestion, however, we prefer those templates to be locked down for design reasons. 

Our users are not happy with this change either, but we will deal with it. 

Thanks. 
Photo of Key Blue

Key Blue

  • 47 Posts
  • 2 Reply Likes
This reply was created from a merged topic originally titled Template Button Gone?.

Does anyone else miss the blue template button under your mailing name in campaign builder that used to allow you to change the template while you were building an email?

We do - It's costing us huge amounts of time when a client wants us to change something like the footer or the number of listing boxes, or a different style of template. It means essentially having to start again content wise with a new mailing. Before we could just change the template no problem and carry on.

I understand that changing templates could cause you to lose text or images if the template is that different, but most people realise this after the first go.

Are there any plans to bring this back? What's most annoying is that it was a feature we used and that was just taken away with no explanation?

What's going on, Emma?


EDIT: Also, why have things gotten so slow? We've had our fibre broadband checked for speed, but in conclusion we're finding since the last update that Emma is really slow, especially after 3pm GMT. Slow as in pressing save usually times out, today I've being kicked out due to inactivity after 3 minutes or so... While waiting for things to load.