My sign up form does not add people to the audience group.

  • 1
  • Problem
  • Updated 10 months ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: EOL CLEANUP

The link on the bottom of our newsletter emails to our sign up form has been tested and our new subscribers are not added to any groups; therefore, they cannot receive the emails they signed up for. I went to audience > forms > signup and saw we had 3 forms. I deleted them and created a new form that I put as "put new subscribers in (name of group). I'm still experiencing problems and I already ran a segment to find subscribers who are stuck without a group. How can I ensure the new subscribers are joining their correct group?

Specifically, how do I change the option for the form link on the bottom of my newsletters to go to a form that actually signs people up?
Photo of alwaysme12345

alwaysme12345

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 10 months ago

  • 1
Photo of Zach Sharpe

Zach Sharpe, Employee

  • 290 Posts
  • 32 Reply Likes
Hello!

The signup link found in the footer area will, by default, link to the signup form that starts in your account (named 'Your Default Signup Form'). You can change this in the review & send portion of sending a mailing. I will attach a screenshot for reference on this.

Lastly, if you have a particular template that you like to use, we can replace the signup form that is attached to that template by default. Just provide the exact template name and the signup form link to replace ( audience > forms > signup > publish this signup form to retrieve the URL).

I hope this helps point you in the right direction!

Thanks!

Zach