Opt-out link added - My Emma still won't let me send test email

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • Answered
I've added the opt-our URL and physical address to my custom email code and MyEmma still won't let me send a test email.  I get the message: CAN-SPAM compliance: (required)CAN-SPAM requires you have an unsubscribe link. You will be unable to send until this is fixed.  What am I missing?
Photo of University of California, Irvine

University of California, Irvine

  • 7 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 0
  • 1
Photo of DeAndre Courtney

DeAndre Courtney, Employee

  • 20 Posts
  • 1 Reply Like
Hey there,

I jumped into your account and seen the error message that you are receiving. This is happening because you have a fully coded mailing that is conflicting with the html code that is already in the editor.

You can learn more about using code in the html block here. You'll need to remove <body>, <head>, <meta>, <title>, <html> or Doctype tags in your HTML. 

We also have a new code your own editor that will allow you to use your own code the way you have it, but you'll need to upgrade your account to get access to that editor. 

Please let me know if you have any additional questions and have a great weekend!

Cheers
Photo of University of California, Irvine

University of California, Irvine

  • 7 Posts
  • 0 Reply Likes
Hello, Thank you for the advice.  I did remove the tags but still have the same problem.  Is there anything else I can do?
Photo of DeAndre Courtney

DeAndre Courtney, Employee

  • 20 Posts
  • 1 Reply Like
Hi there!,

One thing that I would suggest is trying the same code in a Code Your Own template. You can find that option when you click on Create a new mailing > Code Your Own. Please let me know if that helps any.
Photo of University of California, Irvine

University of California, Irvine

  • 7 Posts
  • 0 Reply Likes
Thank you DeAndre, this seems to work!
Marcie
Photo of Pacific Northwest College of Art

Pacific Northwest College of Art

  • 5 Posts
  • 0 Reply Likes
Apologies if this is answered somewhere else, but I'm can't figure this out: 

I'm getting an error message saying that "HTML content is missing a required tag: Optout Link Tag" and that my email requires CAN-SPAM compliance. I've added an opt-out link AND there's the standard True Remove option at the bottom of the email. What am I missing?

This is the first time I'm seeing this error and I don't think I've done anything different.

Thanks for any help!
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1698 Posts
  • 135 Reply Likes
Hi there!  I'm taking a look at this now.  Likely there's a bit of code somewhere in this email that is causing that link to break.  I'm testing a few things in a copy of the donor email and I'll let you know when I find it.
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1698 Posts
  • 135 Reply Likes
Found it!   

It looks like there was a stray HTML block in your mailing that had body tags in it.  This is an EXTRA set of body tags, apart from the ones in the template itself, which is why the proofer was not seeing the Opt-Out link in the footer of the mailing. 

Deleting this HTML block will let you move forward. 

I recorded a video to show you where it is:  http://recordit.co/pTedfZ9jSz

You're welcome to use the Support Copy as it's working now. 

Cheers!

- G 
Photo of Pacific Northwest College of Art

Pacific Northwest College of Art

  • 5 Posts
  • 0 Reply Likes
Ah! A hidden pocket of HTML. Thanks for finding and deleting it, and thanks also for the video. Very helpful.

Much appreciated!