Post Update Errors With Latest v1.3.3 of Emma For Wordpress

  • 1
  • Problem
  • Updated 8 months ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: EOL CLEANUP

I'm suddenly getting errors every time I save a post or page in WordPress after updating to latest versions of WP v4.9.1 and Emma For Wordpress plugin v1.3.3. I'm also using latest version of Divi theme v3.0.90 where the problem may lie with Emma.

Anyone seen this before or know of a workaround or solution? Here's a copy of the error:

Warning: Cannot modify header information - headers already sent by (output started at /home/somovillage/public_html/wp-content/plugins/emma-emarketing-plugin/class-emma-style.php:88) in /home/somovillage/public_html/wp-content/themes/Divi/includes/builder/functions.php on line 2346

Warning: Cannot modify header information - headers already sent by (output started at /home/somovillage/public_html/wp-content/plugins/emma-emarketing-plugin/class-emma-style.php:88) in /home/somovillage/public_html/wp-content/themes/Divi/includes/builder/functions.php on line 2348

Warning: Cannot modify header information - headers already sent by (output started at /home/somovillage/public_html/wp-content/plugins/emma-emarketing-plugin/class-emma-style.php:88) in /home/somovillage/public_html/wp-content/themes/Divi/includes/builder/functions.php on line 2346

Warning: Cannot modify header information - headers already sent by (output started at /home/somovillage/public_html/wp-content/plugins/emma-emarketing-plugin/class-emma-style.php:88) in /home/somovillage/public_html/wp-content/themes/Divi/includes/builder/functions.php on line 2348

Warning: Cannot modify header information - headers already sent by (output started at /home/somovillage/public_html/wp-content/plugins/emma-emarketing-plugin/class-emma-style.php:88) in /home/somovillage/public_html/wp-admin/post.php on line 198

Warning: Cannot modify header information - headers already sent by (output started at /home/somovillage/public_html/wp-content/plugins/emma-emarketing-plugin/class-emma-style.php:88) in /home/somovillage/public_html/wp-includes/pluggable.php on line 1216

Photo of Cliff

Cliff

  • 2 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of Cliff

Cliff

  • 2 Posts
  • 0 Reply Likes
I finally found another plugin that was affecting the error's appearance: OGraphr (an older OpenGraph plugin).

While deactivating Emma For WordPress would stop the error, deactivating OGraphr (while leaving Emma activated) also solved the problem. I got rid of the old OGraphr entirely and all seems fine.

This problem is solved.