Replies going to wrong reply-to email address

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Replies to the last two eblasts sent out are going to the wrong reply to address.  The reply to address should be "DrKings@kingbio.com", which is forwarded to me.  The last two eblasts show "drkings@kingbio.com" as the sender, but when someone clicks reply, it pulls the address of our billing contact instead.  From what I can see, our sender info under Settings is correct, and the correct address was used when we prepared and sent the emails.  Please advise.

Photo of King Bio

King Bio

  • 19 Posts
  • 2 Reply Likes
  • Aggravated. Constant issues with MyEmma.

Posted 4 years ago

  • 0
  • 1
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hey there -- What you're seeing here is actually expected behavior. The reply-to address is supposed to be saved on a per-mailing basis, so the behavior is correct, but if you change the reply-to on a test mailing, then go to review and send, the new reply-to doesn't appear on the review and send page, but does appear in the inbox. It looks like your billing contact's address was manually added as the reply to address on test panel for you latest send.

It's on our radar to improve this functionality so that if you add a reply to address on a test mailing, you can see the same reply to address on the review and send page, so that you know there will be a separate reply to in the inbox. For now, you'll want to be sure to hop back into the test panel to delete any reply to address that you've added there before sending your final review and send.
(Edited)
Photo of King Bio

King Bio

  • 19 Posts
  • 2 Reply Likes
I don't understand.  The biller used her email on a test email three emails ago.  It was not used as a test or an actual mailing for our last two eblasts; yet that is where replies are going from our last eblast, although "DrKings@" is what is listed.  I do not understand the process that you've expressed.  Can you please try to explain it in a different way?  Also, how do I fix this as I do not see the biller's email anywhere other than the billing contact under settings.  I have looked under the "send test" tab, and the "review & send" tab, and the address is all what it should be, "DrKings@".  Please advise.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hey there -- Absolutely, let me see if I can clarify it a bit!

First, I hopped into your most recent sent mailing and found the billing contact's email address added in the reply to field on the send test panel. That mailing name was "Homeopathy Survey 3rd Release." If you're copying that mailing from a previously sent mailing, t's possible that the reply to address is being carried over from the original mailing where it was added. The test panel is intended to save that information, so that is behaving as expected. We're hoping to change the way that interacts with the review and send page, so that you don't have to double check the test panel before saving.

For now, to avoid including that reply to address, you can copy that mailing from the sent tab and delete that reply to address from the test panel. I hope that helps to clarify the situation!