Salesforce Sync Percentage 0%

  • 0
  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved!

I ran the Salesforce Sync a couple days ago and the Setup tab is still saying it is 0%. I haven't received any email verification that it is complete. I can see that Leads are being created but not all my Groups have been imported. I ran it again today and it's still at 0%.
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes

Posted 6 years ago

  • 0
  • 1
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Good afternoon! Have you checked your Salesforce Apex logs to see if anything is noted of having gone wrong? There are a couple of things which could be the culprit

  1. A member field has too many characters to sync properly
    For example, Emma's "short answer" field allows up to 255 characters and is commonly used for "First Name," "Last Name," and "Business Name." However, those individual fields are treated as three unique field types in Salesforce, and they allow much fewer (30-40) characters. Attempting to sync these fields will result in an error in cases where an individual or business has a particularly long name in Emma that is incompatible with Salesforce's character limits. To resolve, adjust these fields in your Emma account and re-start the sync.
  2. An incorrectly formatted email address has sneaked into your Emma audience
    Salesforce and Emma both have built-in protections that guard against incorrectly formatted email addresses like "example@sample@eg.com" (too many "@'s") or "example@sample_eg.com" (invalid character in domain name). However, it's possible to sneak an incorrectly formatted email into Emma via an import. It's a bug that we're working on. Unfortunately, if you happen to have such a record in your Emma audience, the initial sync will stall. To resolve, delete any offending email addresses from your Emma account and re-start the sync.
Please look into these, but if the sync is still stalling please give me a shout and I can reach out to one of our tech specialists to try digging further. We may need access to your Salesforce account, but I can send you some easy instructions on how to give us access.

Thanks!
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
There was nothing noted in my Debug Log, everything was a success. As to your reply, please provide instructions on how to change the character limit on a Emma field. 

So even if one of these things is the issue, shouldn't the percentage go up at least more than 0%. Some groups were created, i just need verification that all of them were.

Also, my users are not able to see the groups that were created. I have them set to see and edit all Emma object records. Can you tell me why this may be happening?
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Resolved the user issues, but still seeing 0% in Emma Setup.
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Good morning! In theory it should jump up more than 0%, but I have seen where it stalls on 0% even though some groups have synced. I’m going to send a note to one of my colleagues for them to dig further on why that sync is locking up. We’ll need access to your Saleforce account to help troubleshoot. Please just follow the easy steps below and give me a shout once you’ve granted us access. 
  1. Click into the "Setup" sub-menu from your personal drop-down menu in the top right corner of your screen.
  2. In the menu to the left of your screen, click "My Personal Information” "Grant Login Access.”
  3. Select "1 week" (or whatever period of time you're comfortable with) next to "Emma Support" and press "Save."
Thanks!
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Hi Tyler,
  
Granted you access for a week. Please let me know how I can resolve this issue, it seems like all contacts are not synced over. 

Thanks,
Samantha
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Hey Samantha! Thank you for the heads up and I’ll let our integrations team know. I will be sure to keep you posted once I hear back from them.

Thanks again!
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Good morning Samantha! I heard back from my colleague and they found a few errors that are causing that sync to stall at 0%. I don’t know the specifics at this point, but our Salesforce developers are investigating and hopefully have resolutions soon. I’ll definitely give you a shout once I have some more information. Please let me know if you have any questions in the mean time.

Thanks!
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Hey Samantha! So there is a new version of the integration and I wanted to see if you can attempt to upgrade to the latest and greatest. Please follow the steps below which should do the trick for fixing the sync stall, but please let me know if you still run into troubles.
  1. Click on this link
  2. Click continue on the page above
  3. Click next on the page that follows
  4. Check install to complete the installation
You will be alerted by email when the installation is complete, at which point you can run quickly through the “Emma Setup” steps to re-run your account sync (all of your earlier selections will be remembered by the app). 

Thanks!
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Hi Tyler, 

I updated the application and am still having the same issue. It is still at 0%. I know that not all my groups are completely synced with all the contacts/leads. Please advise. 

Thanks,
Samantha
Photo of Porter, White & Company

Porter, White & Company

  • 5 Posts
  • 0 Reply Likes
I'm having the same issue -- the update didn't fix the sync, and my sync is stalling at 70%. Please keep me in the loop if there is a solution!

Thanks,
Mary Meadows
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Hey Mary! Can you please grant us access to your Salesforce account as well and just post once you have completed this? I’ll then send a note over to our integrations team to do some digging on your account as well. Here are those steps
  1. Click into the "Setup" sub-menu from your personal drop-down menu in the top right corner of your screen.
  2. In the menu to the left of your screen, click "My Personal Information” "Grant Login Access.”
  3. Select "1 week" (or whatever period of time you're comfortable with) next to "Emma Support" and press "Save.”
Thanks!
Photo of Porter, White & Company

Porter, White & Company

  • 5 Posts
  • 0 Reply Likes
Thanks, Tyler. I granted access. I have been working with Mary Mancini for a while on this too -- just wondering if there were any new revelations.
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Good morning Mary! I do see our Mary is looking into this and already has a ticket open with our integrations team, so I’m going to close the one I opened yesterday. Mary will be sure to keep you posted!
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Good morning Samantha! I heard back from my colleague and there is a different error being generated now, so our developers are looking into this. I will be sure to give you a shout once I have some more information.
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Any updates on a solution?
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Hey Samantha! Our developers are still looking into this, but I unfortunately do not have any new information. I will definitely be sure to keep you posted!
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Is there someone I can talk to on the phone to work through what I can do in the mean time until this get resolved by your developers? 
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Good morning Samantha! Sorry for the troubles and our developers are definitely still digging. To get you moving forward I’d suggest doing a regular import into your Emma audience. Of course the first step would be exporting those contacts from Salesforce. You’ll want to be sure this is exported into an Excel file (either .xls or .xlsx) or a .csv. Once you have this please follow the steps in this link on how to import into your Emma audience.

I wanted to see if you can attempt upgrading as there was a new version recently released. Please follow the steps below.
  1. Click on this link
  2. Click continue on the page above
  3. Click “next” on the page that follows
  4. Check “install” to complete the installation
If this doesn’t fix the issue can you please grant us access again to your Salesforce. I see the access has expired. Here are those steps
  1. Click into the "Setup" sub-menu from your personal drop-down menu in the top right corner of your screen.
  2. In the menu to the left of your screen, click "My Personal Information” "Grant Login Access.”
  3. Select "1 week" (or whatever period of time you're comfortable with) next to "Emma Support" and press "Save.”
Please let me know how the upgrade goes or if you have any questions.
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Tyler, our contacts in Emma need to be moved into SF and deduplcated based on email like I thought your integration could do. We don't need to import any SF contacts into Emma. I have upgraded the package, ran the setup again and it still reads 0% and not all my group members have been synced. I have granted login access. 

Samantha
Photo of Katie Watts

Katie Watts, Support Team Manager

  • 423 Posts
  • 66 Reply Likes
Hi Samantha! 

I'll circle back to our development folks to let them know you've upgraded and are still seeing 0% synced. I'll be in touch as soon as I have an update on that front.

In the mean time, please feel free to manually export your contacts from Emma and import them into Salesforce. If you need some guidance on exporting your contacts from Emma, please check out this help article. Salesforce also has some great guidance on importing into their system.

I'll be in touch on the persisting sync trouble as soon as I know more!
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Hi Katie, 

What is your estimated time for a solution? This has become a critical issue for us and we need to get this resolved asap, as you can see this issue has been open for over 3 weeks now. Does your team provide the data load as a service? If you were to do it or if i were to do it, I would like to speak to someone at Emma to make sure I understand how the sync works if I manually load contacts into Emma Groups in SF. I would like to clarify that the setup issue is just impacting the initial sync and not impacting the everyday back and forth that will happen from Emma to SF and SF to Emma once all the contacts/leads are in both Emma and SF. 

Thanks,
Samantha 
Photo of Katie Watts

Katie Watts, Support Team Manager

  • 423 Posts
  • 66 Reply Likes
Good morning, Samantha.

I understand your frustration on this and appreciate you hanging with us while we work to get the integration running smoothly for you! As soon as I got your post yesterday, I got the case back over to the developers who are working on the sync trouble you're experiencing. I checked back this morning, and they're still working on the ticket and I don't have further information at this time. As soon as they've been able to give me an update, I'll relay that information to you on this thread.

I think I may have misunderstood what you were trying to do when I suggested you could export your Emma audience and import those contacts into Salesforce. I was understanding that you had contacts in Emma that you wanted to add as leads or contacts in your Salesforce account, so I suggested you could manually import those folks to get the records created in Salesforce in the mean time. Until we've got the integration sync issues straightened out on your account, going this route isn't going to do anything to sync the contacts in your Emma and Salesforce accounts -- it's just going to allow you to get your Emma contacts into Salesforce (just like you could have manually done before we offered the integration).

I will continue to check in with the developers on their progress, and as soon as I can wrangle any further details, I'll be in touch. Thanks again for working with us to get this up and running for your account!
Photo of Girls Leadership Institute

Girls Leadership Institute

  • 36 Posts
  • 3 Reply Likes
Hi Katie,

Thanks for all your help with resolving this issue! It looks like the sync is complete and all my contacts are now synced with the correct Emma Group in Salesforce.

Thanks!
Samantha
Photo of Katie Watts

Katie Watts, Support Team Manager

  • 423 Posts
  • 66 Reply Likes
Hi there, Samantha.

So glad you noticed that the issue should be resolved! I just got word from our Salesforce developers this morning that they were able to update you to a brand new version which allowed your sync to complete.

Appreciate all your patience while we dug in on this. Please give me a shout if you run into further Salesforce frustrations!

Thanks a bunch,
Katie