The editor seems to constantly be saving

  • 0
  • 2
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
Save Mode: Emma seems to be in a constant save mode and this makes the design process very slow. It doesn't usually act this way. Is there some setting to change this? I am using Firefox
Photo of The Big Sky Centre for Learning

The Big Sky Centre for Learning

  • 7 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 0
  • 2
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Official Response
Hey there, thanks for posting! Emma does have an autosave feature that's meant to run in the background, and ideally it wouldn't be noticeable, but it sounds like it's getting in the way. Can you describe a little bit more about what's happening? For example, which mailing in your account was running slowly? What were you doing in the account when things were very slow? Was it consistently slow, or did it get slow after certain changes in the campaign? I'd like to see if I can recreate the slowness, and possibly find a way to remedy this. 

We don't have a feature to change the autosave rate, but we are looking into ways to speed up the editor, so any information you have will be helpful! Let me know, and I'll be happy to take a look!
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey there, just wanted to check in! If you have any information to share, it could be very helpful to us! Whenever you have a moment, let me know!
Photo of The Big Sky Centre for Learning

The Big Sky Centre for Learning

  • 7 Posts
  • 0 Reply Likes
Hi Paul. The problem with the auto-save slowing down the editing seemed to have been resolved by signing out of Emma a signing back in again. Thanks.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
That's great to hear! Thanks for letting me know!
Photo of Cynthia

Cynthia

  • 123 Posts
  • 29 Reply Likes
I am also having a problem with the auto-save feature slowing me down. Sure, it does get better when I sign out of Emma then in again, but I keep having to do this every couple of minutes. It's getting very aggravating since I have to do several campaigns this week.
Photo of Cynthia

Cynthia

  • 123 Posts
  • 29 Reply Likes
It happens in any campaign that I do - it constantly occurs and it seems to start immediately when I try to edit a campaign.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey Cynthia, apologies for my delayed response. Could you give me an example of a campaign that's slowing down immediately? I'd like to take a look to see if I can recreate, or if there are any other factors that could be causing the slow down. 

Let me know and I'll take a look!
Photo of Meaghan

Meaghan, Champion

  • 83 Posts
  • 15 Reply Likes
Hey Paul, I was just having the same problem that Cynthia is describing. It happens to me specifically when I am trying to send a test email -- as I update the audience or subject line for the test, it seems to autosave (very slowly) after each step. I just experienced it with the campaign called "BlueOregon 6/11/2015" in our Blue Oregon sub-account.
Photo of Meaghan

Meaghan, Champion

  • 83 Posts
  • 15 Reply Likes
In case this is useful for troubleshooting, I encountered this problem with that specific campaign using Firefox on a Mac. My coworker had no problems with the same campaign, using Chrome on a PC. 
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey Meaghan, I didn't find that exact campaign, but I spent some time with another campaign in that sub-account and I didn't notice the slowness. Is it something that starts to crop up after a few minutes of working on the campaign? Do you find that if you log out, then log back in, it runs smoothly? 

Also, see if clearing cache and cookies has any impact. I wouldn't initially suspect the browser in this case, but we definitely want to rule it out. Give that a try, and let me know if it helps! 
Photo of Cynthia

Cynthia

  • 123 Posts
  • 29 Reply Likes
Paul, when I clear cache and cookies it does seem to move faster but bogs down again within minutes. So that is not the fix that it usually is.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Cynthia, that's great info! I'm a little disappointed that it's only a temporary fix, but it at least gives me some information to work with. Is there a campaign you're currently working in where I could make a copy and do some testing? Let me know that campaign name, I'll take a look!
Photo of New Avenues for Youth

New Avenues for Youth

  • 2 Posts
  • 0 Reply Likes
My co-worker and I are having the same problem - even with different computers/browsers. We end up logging out and/or refreshing the page repeatedly. This happens in every email, but definitely the ones with greater content (such as our newsletters). Please let us know if there's a way to stop the auto-save.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hi! Thanks for posting to let me know! There's no way to disable the autosave, but there are a few things that can help with app speeds in the editor other than clearing your browser's cache and cookies (which I still recommend, just to rule out browser interference). First, make sure that when you start a new mailing, you're heading to Campaigns > Create a new mailing, and picking a blank template. This will start you off with a clean slate, and since old formatting isn't present, it can often speed things up. 

Another thing to keep in mind is the size of images. I took a look at your account, and noticed that some images in your library are quite large: some over 4MB. These large images will definitely slow things down, so you might consider deleting any large images and re-uploading them as a smaller file, if you need them at all. 

Give those two things a try, and if things are still running slowly, let me know the name of the campaign! 
Photo of New Avenues for Youth

New Avenues for Youth

  • 2 Posts
  • 0 Reply Likes
I'm working on a new email and followed your advice. I started from a blank template and I resized the one image in the email to make sure it's small. Still Emma is moving slow for us.
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Thanks for letting me know! I just glanced at your image library, and I would still recommend deleting any large images (over 2MB or so). Even if they aren't in the mailing you're working on, they can still slow things down. This isn't the only reason your account might feel sluggish, but removing those images can certainly help. 

We've also come to realize our site tends to be sluggish during peak hours, and have launched a major effort to speed things up in our app. You'll definitely see things improve over the next few weeks. Take a look at this thread to keep up do date with our latest performance improvements. It's our goal to release fixes on a daily basis to speed things up! 
Photo of Cynthia

Cynthia

  • 123 Posts
  • 29 Reply Likes
I've definitively noticed that peak hours slow things down to a crawl. You are on the right track!
Photo of Paul Zimmerman-Clayton

Paul Zimmerman-Clayton, Official Rep

  • 400 Posts
  • 34 Reply Likes
Hey folks, I just wanted to touch base on an improvement we just released. In our ongoing effort to improve our app's speed (more on that here), we've decoupled the proofing process from the autosave process. This means that autosave will still run, but we'll only proof your email for broken links, size, and other issues when you click to send a test or send your mailing. 

Hopefully this will resolve some of the speed issues associated with the autosave process, especially on large mailings. Please let me know if you have any more questions!