Segmenting using "any of the above" vs. "all of the above"

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
  • (Edited)
Using Chrome Version 46.0.2490.86 (64-bit).

I created a segment to find people in multiple groups, as well as excluding some with particular contact info. When I run the segment, it tells me there are no contacts to show. I know for a fact there are around 6000 contacts that should appear. It worked the last time I had to send to the segment on November 2, but it isn't working now. 



Photo of College of Saint Elizabeth

College of Saint Elizabeth

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Sam Collis

Sam Collis, Customer Support Specialist

  • 252 Posts
  • 59 Reply Likes
Official Response
Hi there!

First, let me thank you for your detailed description and your screenshots.  You've made it very clear what you're trying to do and given a perfect amount of information for me to see what's going on here.  

I can see from the first screenshot that you're using the and parameters in your search.  What you're actually searching for is contacts that are in all of those groups, and not contacts that are in any of those groups listed.   I'm assuming that you're not trying to find contacts that are in all the groups as that would only be able to return a maximum of 11 contacts (as that is the smallest group) - and in fact in this case is returning none.

No need to worry - the solution is quite simple - head back over to that segment you've created and from that screen of the first screenshot, select the edit button next to the list of groups.  All you need to do is select "any of the above" at the bottom of the list and you'll now be searching for contacts that exists in any of those groups selected.  I thought I would return the favour and include a screenshot to further show what I mean.


You should be good to go once you've done all that, but please let me know if there's any additional questions :)
(Edited)