Slow load speed in platform.

  • 1
  • Problem
  • Updated 7 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: EOL CLEANUP

I'm noticing that things are taking much longer to load than normal. For example going from Home to Campaigns takes a while to load. Then opening a Campaign takes a long time. Choosing an image - it takes forever to load my library. Is there any way to fix this? Should I clean out our image library to speed things up?
Photo of Thibaut

Thibaut

  • 5 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Laura Dickerson

Laura Dickerson, Official Rep

  • 778 Posts
  • 64 Reply Likes
Hi there,

I just took a look at your image library and you do have quite a few images in there. 1,245 or thereabouts the earliest being from 2013. I would clean out some of those earlier images to get your image loading time back to normal. We are working on the overall speed. Hopefully you will notice a change in that soon. 
Photo of Thibaut

Thibaut

  • 5 Posts
  • 0 Reply Likes
Hi Laura,

Thanks so much for your reply. By deleting images out of our image library, will it disrupt campaigns that haven't been sent yet or ones that were recently sent? Or as long as a campaign has been sent, images used in it can be deleted from the image library.
Photo of Laura Dickerson

Laura Dickerson, Official Rep

  • 778 Posts
  • 64 Reply Likes
You should delete the oldest ones, the ones that you know for sure you haven't, or aren't, going to be using again. That way there is no danger of images not showing up in more current mailings. You don't have to save the images to the library for them to show up in your mailing, but it is always a good idea to have them there. 
Photo of Entrepreneurs' Organization

Entrepreneurs' Organization

  • 6 Posts
  • 0 Reply Likes
Laura: 
Our team has also noticed the platform dragging a little. Are there any other factors (other than the number of images we have in our library) that may slow Emma down? For example, number of unset draft campaigns or the number of our team members in the platform at one time, etc? 
Thank you. 
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hi there!   The things you listed shouldn't have any bearing on how the platform runs.  Typically if things start dragging I'll know it's time to clear the cache and cookies from my browser.  

You'll want to make sure your browser is fully updated as well.  We suggest using Chrome or Firefox.  And I suggest clearing cache and cookies once a week.  
Photo of The Lens

The Lens

  • 9 Posts
  • 1 Reply Like
I have the same problem. page loads for ever and I cannot access my campaign mailings. No related to images, just takes forever.
Photo of Phillip M

Phillip M, Official Rep

  • 247 Posts
  • 20 Reply Likes
Hi!

I think the above troubleshooting steps are a great place to start and here is a consolidated list of things to try:

- If using Chrome, try an Incognito window (cmd + shift + N)
- try a different browser
- update browser
- clear cache and cookies
- restart browser / computer
​- try a different network (if this clears up the issue, then reach out to your IT team or your ISP to let them know)

I hope this helps, but just let me know if you need anything else on this one. - Thanks!