Social Sharing of mailing only goes to personal Facebook account, not business Facebook

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
When I try to share our mailing on social media, it connects to my personal Facebook account rather than my business page. There are no dropdowns or anything else that would allow me to change over to the business page. 

I've looked through the most recent posts here, but none of them are helpful in solving the issue. Any advice?
Photo of Doha Family

Doha Family

  • 10 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1642 Posts
  • 131 Reply Likes
Official Response
Hi there Doha Family, 

I popped into your account and saw that, under the drop down for sharing on Facebook, there wasn't a business page listed.  I'm thinking that perhaps the Emma Social Connector wasn't given permission to post on that page in Facebook.  You'll want to check your settings there.  

This article from our Resource Center talks about giving permissions when you first sign in to Facebook via Emma, but I believe you may need to go into the app settings in Facebook and make sure the Emma Social Connector has permission to "Publish as pages you manage".  

It looks like this in Facebook:

Then, in Emma, you can select which page to post to via the methods described here with handy screen shots:
Posting to Facebook Business Page Instead Of Personal

Let me know once you get that connected and if you have any more questions!

- Grey