Survey link opening to thank-you page instead of actual survey

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
I'm sending out a second request for a survey to be completed, but the link to the (still active) survey, opens to the survey's thank-you page. How can I make sure that it opens to the survey for recipients who have not yet responded.
Photo of Legal Files Software

Legal Files Software

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 0
  • 1
Photo of Ben Vance

Ben Vance, Alum

  • 328 Posts
  • 14 Reply Likes
Hi! If you’re resending a survey, you’ll want to be sure that you’re either using the direct link or that you’re reinserting the survey link into your campaign from scratch.

When you insert a survey link into your campaign and send it out, each recipient gets a unique link that’s tied specifically to them as a member of your audience. Once they complete the survey, if they re-visit that link it will continue to redirect them to the thank you page. So, if you’ve taken the survey before and are using that specific link to send again, it will send everyone back to the survey page.

Going through the process of inserting a link, and selecting the appropriate survey will send out a fresh new link to each of those members. You can also use the direct link - which isn’t tied to any single recipient. You can find the direct link for the survey, by opening the survey from your campaigns page, then selecting the “publish” tab.

I hope this helps, and please let me know if you have other questions!
Photo of Legal Files Software

Legal Files Software

  • 4 Posts
  • 0 Reply Likes
Thanks Ben. I inserted the direct link to the survey into my campaign. When I preview it, it opens to the correct page. When I send a test to my email, it still opens to the thank-you page. Is this what is expected?
Photo of Ben Vance

Ben Vance, Alum

  • 328 Posts
  • 14 Reply Likes
Have you already submitted a response using the direct survey link as well? If you have, then your browser cache is remembering that you’ve answered the survey already. I just clicked on the link you used in your latest test and was taken to the survey, not the thank-you page.
Photo of Legal Files Software

Legal Files Software

  • 4 Posts
  • 0 Reply Likes
Thanks Ben!
Photo of McLane

McLane

  • 1 Post
  • 0 Reply Likes
I'm actually getting this same problem on a reminder email I'm trying to send out.

I tried deleting my cookies, opening the survey in Internet Explorer (Chrome is my default), and forwarding the Test email to two co-workers that never received the original email, and it comes back with the "thank you" page in each scenario.

Any assistance you can provide would be greatly appreciated.  I'd like to get this email out ASAP, and am just waiting on figuring out how to resolve this issue.  

The email I'm referencing is titled "MA ELPG Seminar Reminder with Descriptions" and the survey is titled "Massachusetts Employment Law Update."  The link in the email is at the bottom "Click Here to Register!"

Thanks!
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi McLane -- When you send that survey link out in an email through Emma, it personlizes the URL to the recipient. So, if they've already taken the survey, they will be directed to the Thank You page. Since this is a reminder email, I think that is likely the case. 

You could avoid this by posting the survey link online instead of sending it out in an email. You could post it on your Facebook or on a page of your website and direct your contacts there in the reminder email. Since the survey link is being hosted instead of emailed out, it will remain a public rather than personalized link!

I hope this helps!