Sync with Salesforce is broken

  • 1
  • Problem
  • Updated 1 year ago
Browser: Version 59.0.3071.86 (Official Build) (64-bit)

There is an issue in my org regarding many types of exceptions.  They are being traced to Emma apex classes.  I tried to re-sync and found that the integration is requiring fields such as Emma Sync Message, Emma Sync Date and Emma Sync. These fields exist on both my Lead and Contact objects. However, when I try to map them in Emma setup those fields are not available.  It's like they don't exist. I've attached a screenshot.

So I cannot even sync SF and Emma at this time to see if that fixes the issue. I think another person with administrative privileges may have updated the Emma app in SF and your site was down on Friday (6/23/2017), so I thought that had something to do with it. But your site was back up.

I also noticed that the drop-down list of fields does not include recently created fields, so I'm wondering if the list of available fields isn't updated. But how do I sync to fields that are not available in the picklist???
Photo of Clean Energy Collective

Clean Energy Collective

  • 25 Posts
  • 3 Reply Likes

Posted 1 year ago

  • 1
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hey there!  From initial glance it looks like the entire setup may need to be rerun and authorization made through the Emma Setup.  

I'd start with walking through these steps, specifically Step 1 of PART 7 , the account verification section:
 https://support.e2ma.net/Resource_Center/Guide_to_Integrations/Emma_for_Salesforce_Installation_Guid... 

Go ahead and give that a try and see if your fields are showing up after reauthorizing.  

If not, go ahead and grant us support access to your account via these instructions:
https://support.e2ma.net/Resource_Center/Guide_to_Integrations/Emma_for_Salesforce%3A_Support_Access

Also, we noticed that you have some Sandboxes set up too.  You'll want to make sure you don't have the Emma integration set up on a Sandbox.  You'll only want to have it in Production. 

Let me know and we'll pop in and take a look.  

- Grey 
Photo of Clean Energy Collective

Clean Energy Collective

  • 25 Posts
  • 3 Reply Likes
Hey Grey,

Thanks for the reply.  I can only complete Step 1 of Part 7...And that's the problem.  I can start the setup, enter public and private keys, my account ID and then I can verify. All that works great. But I still cannot see fields in the picklist that I know for a fact exist on the Lead and Contact objects.

I appreciate the heads up about the sandboxes but I foresee an issue. First, do you recommend uninstalling Emma from my sandboxes?  I can do that but it will just be added back when I update the sandbox again to replicate my org.  Now since I've generated new keys within Emma for production, the sandboxes shouldn't be connected, correct?  But when I refresh my sandbox again the current keys will exist in the sandbox.  Is the workaround for this to just remove from the sandbox manually each time? Please advise on that.

It sounds like I'll need your help directly in my org. I've gone ahead and granted access to our our for Emma Support...for one week expiring on 7/4/2017.  Please let me know if you need anything else and I appreciate the help.

Thanks,
Dom
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Thanks for passing that along.  It's really helpful for us!  

I'll need to check in with someone regarding the Sandbox setups.  We do strongly suggest not having the integration set up in production AND sandbox, as they would both be trying to connect to Emma and that can break things.  

Yes, generating new keys should disconnect any existing connections.  I'll check in with my team here to see what the best option is for that moving forward.  

I'll be back in touch soon!

-Grey
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1700 Posts
  • 135 Reply Likes
Hey there!   Thanks for your patience with us.  I hope you had a great holiday! 

It looks like we need to head back to the beginning of the setup process, back to "PART 2" :
https://support.e2ma.net/Resource_Center/Guide_to_Integrations/Emma_for_Salesforce_Installation_Guid...

And walk back through the entire setup again.  

If you wouldn't mind checking that out and let me know how it goes once you get to "PART 7".

- G