The text editor toolbar is missing. I can't change any text to a link, make bold, etc...

  • 0
  • 5
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Main issue resolved; haven’t heard back from other Emma users.

As you can see from the picture, I'm trying to modify a link. There is no toolbar. I tried going to preview and then going back to the editor, but I still get nothing. When I went all the way out to Campaigns, and then went back it was there.

My question is, how do I get the toolbar back without completely exiting the newsletter?

Photo of The MIHOW Program

The MIHOW Program

  • 6 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 0
  • 5
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I'm sorry for the trouble you're experiencing! It must be frustrating. Would you mind giving this a try?: When you go back to your campaign and the toolbar appears, try pinning it in place by clicking the little pushpin icon at the far right when you hover over the toolbar:



We're fixing the disappearing toolbar, but pinning it should keep it in place in the meantime.
Photo of The MIHOW Program

The MIHOW Program

  • 6 Posts
  • 0 Reply Likes
I'm not sure if I should reply to you or to the thread. But pinning doesn't work. Please see my additional post in this thread.
Photo of The MIHOW Program

The MIHOW Program

  • 6 Posts
  • 0 Reply Likes
Thanks for the response Katie, but it is already pinned. I did figure out what causes it to disappear though. Every time I go to edit the source code the toolbar is gone when I exit the html code window. I believe it is a bug.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I want to make sure I'm following your same steps. Here's what I've tried:

  1. Click inside a text box, and pin the toolbar.
  2. Click the HTML button at the toolbar's far-right -- that looks like this: </> -- to open the HTML behind that text box.
  3. Make changes to the code, then click Save.
  4. Notice the toolbar isn't there. I click inside that text box, and the toolbar appears.
It seems to me as though when I save the changes I've made to the text box's HTML, it saves but I'm no longer technically working in that text box, so the toolbar doesn't display (since it only displays when you've clicked inside a text box). Does that sounds like what you're experiencing?
Photo of The MIHOW Program

The MIHOW Program

  • 6 Posts
  • 0 Reply Likes
It sounded like what I was doing but I followed all your steps to make sure. The bug happens if I look at the source code but don't make any changes so I hit cancel to get out the window.

I just tried it again and although I didn't have any changes I hit "save" to exit the html code and the toolbar remained.

It appears to only disappear when you "cancel" out of the html code.

Could you check on your end?
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I've created a copy of your campaign and titled it "Car Seat Check - Emma copy" to troubleshoot. Is there a specific text box where this happens? When I click in a text box, click to view the HTML and either Save or Cancel, the toolbar does go away for me. It sounds like it's only vanishing for you when you click Cancel, but then when you click in the text box again, the toolbar doesn't appear.

That isn't what I'm experiencing, so in addition to testing the same text box you are, I'd like to gather a few more details: Will you please let me know the web browser and version you're using? You can go to www.supportdetails.com to have them automatically detected. I'm using Firefox 24, for reference.
Photo of The MIHOW Program

The MIHOW Program

  • 6 Posts
  • 0 Reply Likes
Sorry it took so long to get back to you. I'm using Chrome 30.

There is not a specific text box I'm using. I've tried it from the caption under the first picture and both text boxes in the right column. Each time once I cancel out of the html code, the toolbar disappears no matter where I put the cursor (I tried a variety of text boxes and captions).

Also, each time I "save" out of the html code, the toolbar remains no matter which text box or caption I'm in.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Hmm. That's the version of Chrome I'm using, too. Just to clarify, when you cancel out of the HTML and the toolbar disappears, it does not reappear when you click back into the text box?
Photo of The MIHOW Program

The MIHOW Program

  • 6 Posts
  • 0 Reply Likes
Correct. It does not reappear when I click the original text box I was checking the html for AND when I click in any other text box AND when I go to "preview" and then back to the editor to try and reset everything. It only comes back when I completely exit out of the campaign.

It does stay pinned when I "save" out of the html though.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I'm reporting this to our technical support specialist to see if she has some ideas. I'll keep you posted!
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Thanks for your patience! We've been troubleshooting here, but we're still having a tough time replicating this, so I'm wondering if there's something you're doing differently that might seem inconsequential or there's a setting on your machine is contributing to how the toolbar opens.

Would you be up for making a screencast of your process or trying on a different computer?
Photo of Kelly

Kelly

  • 84 Posts
  • 9 Reply Likes
I'm having this issue as well, but I am not editing any html code. It just happens after I've been editing for a bit. All of a sudden, I'll go back to a content block I previously edited and the tool bar won't be there. I've also tried exiting and reentering the campaign. No luck.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
When this happens, has the toolbar been pinned in place? If so, is there a specific campaign in which this happens more than others?
Photo of Kelly

Kelly

  • 84 Posts
  • 9 Reply Likes
I thought it was happening even with the bar pinned, but perhaps not. That seems to be working. THank you!
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I'm glad to hear it! The toolbar should be pinned by default, so if it's pinned yet disappearing, that's a red flag. But if it's unpinned and floating around, I suggest pinning it in place so it stays put. :)
Photo of Farmington Financial Group

Farmington Financial Group

  • 4 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled
The text tool bar disappeared.


The text tool bar disappeared and doesn't appear even if I add more text and text boxes? Where did it go and how do I get it bacl to customize my text. I've clicked and highlighted the next. I don't see it.
Photo of Orange City Area Health System

Orange City Area Health System

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Where did the text editing options go?.


I was working on a new campaign, using the new drag and drop editor, and for some reason the ability to manipulate the text (e.g. add a link, etc.) disappeared. Where do I find those editing options?
Photo of Earth Advantage

Earth Advantage

  • 1 Post
  • 0 Reply Likes
Did you ever get an answer? I am experiencing the same issue.

The only way that we have been able to use Emma is to copy old emails and type in new text exactly where the old text was using the styles that were existing in the old email. Any new text areas created using the drag and drop editor seem to be corrupt. I have the ability to style the text for a while, but seemingly without warning, the text stops accepting changes, then the text tool bar disappears and doesn't reappear when I click out of and back into the text area and it wont appear when I click within a different text area either.

The entire Emma system seems to be getting slower and more unreliable as time goes on.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I’m sorry to hear this! If your text editing toolbar is pinned in place but it is still disappearing, will you please let me know in which mailing you’re working, and I’ll take a look?

Also, in which web browser are you working? I’m in Firefox 25, for example. If you aren’t sure of your browser’s version — I want to make sure you’re in a compatible browser — you can go to www.supportdetails.com to have the browser version detected automatically.
Photo of leiva

leiva

  • 6 Posts
  • 0 Reply Likes
I don't have an editor toolbar at all!! Ack!!! Help!
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Hi! I spotted your post here first and replied in that conversation, if you'd like to keep the chat going from there. :)
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Hello, all! This morning, we released a fix to a bug that might have been what you were encountering: When scrolled to the bottom of a mailing, if you clicked in a text box and pinned then unpinned the toolbar, when you clicked in that text box again, the toolbar appeared way below the mailing. You'd have to zoom out to see it, so it looked as though it wasn't appearing at all.

If you’d be up for it, I’d love for you to test again to see if you’re getting the toolbar! Please let me know if you’re still having a problem.
Photo of Corrections Corporation of America

Corrections Corporation of America

  • 6 Posts
  • 0 Reply Likes
I do  not have a toolbar at all. When I go to edit my mailing using one of my customed designed templates, I have no toolbar to edit the text. Help please.
Photo of Corrections Corporation of America

Corrections Corporation of America

  • 6 Posts
  • 0 Reply Likes
Yes, I will attempt to use Firefox
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Great, keep me posted!
Photo of Corrections Corporation of America

Corrections Corporation of America

  • 6 Posts
  • 0 Reply Likes
Okay, the toolbar is showing up in this browser. I can continue to use Firefox to create my mailings.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Terrific! Sorry to have to switch browsers on you, but you’ll have a much better experience in Firefox. :)
Photo of Becca Green

Becca Green

  • 2 Posts
  • 0 Reply Likes
I am having the same problem; can you help?
Photo of Becca Green

Becca Green

  • 2 Posts
  • 0 Reply Likes
I am using Chrome Version 31.0.1650.63, but I also tried in Safari and Firefox. Still no toolbar.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
I’m sorry to hear it, Becca! I jumped into your latest mailing using Firefox and then Chrome. When I click into a text box, the formatting toolbar appears along the top:



Would you mind walking me through the steps you’re following when the toolbar doesn’t appear? Is this happening in another mailing, other than 1-24-14 Weekly Update?
Photo of Laurelhurst School

Laurelhurst School

  • 2 Posts
  • 0 Reply Likes
Me too! Using IE 9.0 (with no option to change browsers as I'm on a work trip with a work laptop and need to get this fixed within the next 18 hours...No toolbar what so ever. I try exiting and re-entering campaign, can't get a toolbar to save my life. Suggestions?
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Hi there! I’m not able to test in IE 9, but I can confirm the toolbar is working in Firefox 26 when I jump into your mailing called "19 - Jan. 31.” Is it possible you inadvertently unpinned the toolbar? This happens by clicking the pin button at the far right of the toolbar, which makes the toolbar float. When that happens, the toolbar might appear at the very bottom of your mailing, out of sight. Are you able to click within a text box then scroll to the bottom of your mailing to see if you spot it?
Photo of Gruve Technologies, Inc.

Gruve Technologies, Inc.

  • 1 Post
  • 0 Reply Likes
I'm having the same problem. My toolbar is gone and I don't know how to get it back. I've checked the bottom and don't see it.
Photo of Katie Lewis

Katie Lewis, Official Rep

  • 3414 Posts
  • 309 Reply Likes
Hello! I jumped into your most recent mailing, and the formatting toolbar appears as soon as I click into a text box. Will you please let me know the web browser and version you’re using? Does this happen no matter which browser you’re in?