Very slow access to audience list

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: resolved

I am trying to fix all of the errors in my total audience list. When I do make a change and it refreshes is it taking 30-60 seconds to get the data. It draws the page quickly, but then the LOADING icon appears and keeps there for all of this time.

I need to update this urgently for a new mailing, and I have about 400 still to work on and all of my time is spent waiting.

Can you please recommend a solution for this. I have even considered exporting them, fixing them and then reimporting.
Photo of The ETHER Initiative

The ETHER Initiative

  • 16 Posts
  • 0 Reply Likes
  • time is being wasted

Posted 4 years ago

  • 1
Photo of Benton Cummings

Benton Cummings, Senior Manager, Customer Support

  • 491 Posts
  • 52 Reply Likes
Hi Roger,

We'd communicated via email about this shortly after you posted, but I realized we hadn't followed up here on the conversation.

Can you confirm if my last recommendation to clear cache and cookies offered any relief from the slow page loads? 

I'd also love to point you toward this community thread where we've been discussing our plans to improve overall performance of the application. We're committed to making Emma faster and easier to use, and David has been detailing our commitment in that thread, so I'd definitely recommend giving that a read.

Don't hesitate to let us know if you're still running into any issues- we're always happy to help!