What causes 'Pending' status of a contact in a Salesforce Emma Group? The group will not refresh if there is a member with 'Pending' status.

  • 0
  • 2
  • Question
  • Updated 8 months ago
What causes 'Pending' status of a lead or contact in a Salesforce Emma Group? The group will not refresh if there is a member with 'Pending' status. What does 'Pending' mean? Once a lead or contact is tagged as 'Pending', the status doesn't seem to change.

Photo of Saratech Marketing

Saratech Marketing

  • 4 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 0
  • 2
Photo of Adriane Smith

Adriane Smith, Customer Support Specialist

  • 506 Posts
  • 53 Reply Likes
Hi Saratech Marketing!

Thank you for reaching out about this. Anything listed as “pending” in Salesforce means that the sync isn’t complete on that object — whether it be a lead, contact, group, etc. If you're thinking something has stalled and something showing as “pending” is no longer moving, you can grant login access to us at Emma and we can have a look at that for you.  

Let me know if there's something we can assist with here. In case you need it, here are steps on how to grant Emma access. 
Photo of Saratech Marketing

Saratech Marketing

  • 4 Posts
  • 0 Reply Likes
Thanks for your response Adriane. Yes I think there is something wrong with our Salesforce and Emma sync. A lot of leads and contacts are in pending and we have not had an Emma Mailing campaign updated in our Salesforce since 1/17/17 (Emma Mailing ID: 16967900)

I will ask our IT to grant access to Emma for 1 week starting tomorrow. Is there a more direct way to contact you?
Photo of Saratech Marketing

Saratech Marketing

  • 4 Posts
  • 0 Reply Likes
I was informed by our IT department that Emma Support should now have access for one week.
Photo of Adriane Smith

Adriane Smith, Customer Support Specialist

  • 506 Posts
  • 53 Reply Likes
Thank you! I'll pass the information along, and will be back in touch once I know more. 
Photo of Adriane Smith

Adriane Smith, Customer Support Specialist

  • 506 Posts
  • 53 Reply Likes
Hey Saratech,

We think you may be having an issue with Oauth (which is what gives permission for Emma's Response information to sync to Salesforce. Can you go back into Salesforce as a Salesforce admin and click on the "Emma Setup" tab. On the first step there is a "connect to salesforce" button and you'll need to click on that, then click production, and then follow the prompt to give Salesforce permission.

After you've done that you just need to click through the remaining Emma setup steps and finish by clicking the "Complete Setup" button. 

Once you're done and the sync has completed you should see response come through. If you don't, let me know and we'll dig back in!
Photo of Eric Mannino

Eric Mannino

  • 2 Posts
  • 0 Reply Likes
I am having this same exact issue.  Please let me know whom I should call.
Photo of Adriane Smith

Adriane Smith, Customer Support Specialist

  • 506 Posts
  • 53 Reply Likes
Hi Eric! Thank you for adding this to the conversation. If you can grant Emma access to your Salesforce account, we'd be happy to jump in and have a look there. Thank you in advance!
Photo of Eric Mannino

Eric Mannino

  • 2 Posts
  • 0 Reply Likes
Thank you.  I have granted access.  However, after reading your response to Saratech, I think I had the same issue.  I just ran the connect to salesforce again in Set up and it appears it may be working.  I wouldn't mind having someone go in and confirm that it's set up properly and that the problem is fixed.  Thanks in advance.
Photo of Adriane Smith

Adriane Smith, Customer Support Specialist

  • 506 Posts
  • 53 Reply Likes
Hi Eric!

So sorry for my delay here! Do we still have access to your Salesforce account? I'll have a savvy colleague go in and check that out for you. It may be the same as what Saratech was describing, but I'm not certain! Let me know how long we've got access to it and I'll have someone jump in to check it out. Thanks!!
Photo of Adriane Smith

Adriane Smith, Customer Support Specialist

  • 506 Posts
  • 53 Reply Likes
Hello Eric, 

Just checking back in with you to see if we can still help with those contacts syncing in Salesforce. If I can still help, just give me a shout!
Photo of Ben Hatten

Ben Hatten

  • 2 Posts
  • 0 Reply Likes
Hi Adriane - we're having the same issue.  In looking at the error logs, we see this:


Insert failed. First exception on row 0; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, emma.SyncEntry: execution of AfterInsert

caused by: System.UnexpectedException: common.exception.SqlDupValOnIndexException: ORA-00001: unique constraint (CORE.AKC

I just granted access to our salesforce instance - can you give us a hand?
Photo of Grey Stepp

Grey Stepp, Support Team Manager

  • 1695 Posts
  • 135 Reply Likes
Hey Ben, sorry for the delay in getting back to you on this.  

Do we still have access granted for your org?  
Photo of Ben Hatten

Ben Hatten

  • 2 Posts
  • 0 Reply Likes
Yup, just regranted.  Sorry this went to spam. 
Photo of Ben Harrington

Ben Harrington, Employee

  • 112 Posts
  • 12 Reply Likes
Hey Ben! When trying to refresh a group based on a report in your org we were unable to replicate the error. I believe that the error may have been a one-off error related to the group that it is based off of and since we were unable to get the error to show up we think the issue that may have been causing the sync to pause must have passed. 

If this happens again , could you relay the report that is causing the error?

Thanks! 
Photo of CommonBond

CommonBond

  • 11 Posts
  • 0 Reply Likes
Hi everyone!

We are having the same issue (with pending Contacts), the access is granted for a week from now.
Let me know if you need any assistance from us please!

In addition, there is less important, but still an issue with Groups sync: we have 499 Groups to be synced, but every time we start the process, it fails with the 2nd in the queue. We have found a workaround for that, but it is not convenient a bit.

Kind regards,
Sergey
Photo of CommonBond

CommonBond

  • 11 Posts
  • 0 Reply Likes
Guys,

Is there a chance you could review my request please?

Thanks in advance!
Photo of Ben Harrington

Ben Harrington, Employee

  • 112 Posts
  • 12 Reply Likes
Hi There! 
We are currently looking into this, and I will update you when I have some more info! 

-Ben
Photo of Ben Harrington

Ben Harrington, Employee

  • 112 Posts
  • 12 Reply Likes
Need to make private

Please reference the new conversation here: SalesForce Pending Issues
Photo of Hopa Mountain

Hopa Mountain

  • 3 Posts
  • 0 Reply Likes
Hello,
I am having a similar problem. I allowed Salesforce access through the Emma Setup tab and completed set up, but I still have 67 contacts that will not sync with My Emma. Either they are "Pending -- Send Inherited Memberships" or they have an Error message. Since I allowed Salesforce access and completed set up yesterday, the EmmaConnectorGroupRefresh 2017-09-25 16:22:22 hasn'tcompleted, and has just said "WAITING" for the past 15 hours. 
Any other ideas as to what could be wrong if it is not the Oauth connection?
Photo of Heather Sturm

Heather Sturm, Integrations Support Specialist

  • 99 Posts
  • 3 Reply Likes
Hello Hopa Mountain! 

Thanks for providing access in advance! I'm currently looking in your Salesforce org, and it looks like many of the contacts that are pending are in error or opt out status and/or have no group membership in Emma. I corrected some of the permission settings for the Emma for Salesforce integration and re-ran the sync. I'm going through now and manually syncing all the "pending" contacts I see.

It should be corrected for you soon, and if you see the issue resurface, please let us know!

Cheers,
Heather
Photo of Hopa Mountain

Hopa Mountain

  • 3 Posts
  • 0 Reply Likes
Thank you, Heather! We are still having trouble with the Emma Response Activities related list. For some reason, this aspect does not appear to be syncing with most of our contacts/Emma members. We send monthly emails, but for many of the contacts, the only response activities listed are from 2016 and 2015. Some have a few response activities listed for 2017, but I have yet to find a contact (except for newly added ones) that has response activities that are fully up to date. Why is this?
Photo of Heather Sturm

Heather Sturm, Integrations Support Specialist

  • 99 Posts
  • 3 Reply Likes
You're welcome! I spot checked several your contacts against the Emma Response Activities, and it seems to be syncing correctly now. Would you mind checking again?

I did update some permissions inside Salesforce, so it is possible that one of the changes I made allowed the data to sync over.

If you're still seeing discrepancies, please provide the specific mailing name(s) and we can look closer!

Cheers,
Heather
Photo of Hopa Mountain

Hopa Mountain

  • 3 Posts
  • 0 Reply Likes
Hi Heather,
I am still seeing discrepancies. Is there a way for me to privately give you some of the specific mailing names? Thanks!

Hopa Mountain
Photo of Heather Sturm

Heather Sturm, Integrations Support Specialist

  • 99 Posts
  • 3 Reply Likes
Yes, I will email you and we can continue troubleshooting this offline! 

Thanks,
Heather