Whenever I try to send a test email, I get an error saying "Whoops, something went wrong"

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
This error happens at the "proofing" step. I've tried logging out and in, "clearing all website data" in Safari (I'm assuming that clears the cookies and cache), and even tried logging in through Chrome and I still get the same error. I'm using Safari 9.0.1.

[As an aside, I don't know what "Get Satisfaction" is but, it isn't giving satisfaction. It wouldn't let me log in with my My Emma account, and then when I finally relented and logged in with Google, it deleted the description that I wrote initially. As someone who has paid MyEmma for years now and has been a completely painless, low-demand customer, this support process is really irritating.]
Photo of Paul Hughes

Paul Hughes

  • 5 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 0
  • 1
Photo of Paul Hughes

Paul Hughes

  • 5 Posts
  • 0 Reply Likes
Is this really my sole recourse for getting help from MyEmma? I guess I'll try calling in the a.m. I really need to get this email sent.
Photo of Sam Collis

Sam Collis, Customer Support Specialist

  • 252 Posts
  • 59 Reply Likes
Hi Paul.

I'm sorry to see you're irritated.  You've absolutely done the correct initial steps to troubleshoot this one.  My feeling is that it's an issue within the HTML that's causing the proofer to crash - but I'm not 100% sure and so I'm going to go ahead and loop some of my colleagues in.  I made myself a test copy of 3 mailings, 2 of which I experienced the same issue - so it's definitely not a problem with your browser (as you've already figured out).

Apologies for the delayed response, Paul and we do appreciate your patience on this one.
(Edited)
Photo of Paul Hughes

Paul Hughes

  • 5 Posts
  • 0 Reply Likes
Thank you, Sam! I appreciate your work figuring this out. I'm using the exact same HTML template I've used for all our previous newsletters for years (I'm just swapping in new text and new image urls), so I don't know what might be causing the issue. I would really like to send this out today (it's for Halloween and the clock is ticking), so please keep me posted.
Photo of Sam Collis

Sam Collis, Customer Support Specialist

  • 252 Posts
  • 59 Reply Likes
Official Response
Hi Paul,

Thanks again for your patience.  After doing some digging around we found that removing the following characters from your code actually stopped the errors and allowed a test to send: 

’ 
— 
“ 
” 

If you take a look at 'Support - October 2015 - BC," we've replaced those with the actual special characters in the live text, and that copy is behaving normally in the editor and at the send process. Below are the changes we made:

’ replaced with ' 
— replaced with - 
“ replaced with " 
” replaced with " 

We also noticed that you're using <html>, <head> and <body> tags which we recommend avoiding as they can cause an email to behave strangely.  You can check out our HTML best practices guide here.

We are going to take a further look into this one for potential issues in the future, but using this workaround should enable you to send your mailing as normal.

Finally, I wanted to address your issues with logging into community - did you log in directly at community.myemma.com, or did you jump from your account using the "?" button?  We definitely want to make sure that our customers are always able to get in touch with support so we'd love to make sure you don't have further issues.  Moving forward,  you can also email us anytime at support@myemma.com

Please let me know if there's anything else I can do for you, Paul!
(Edited)
Photo of Paul Hughes

Paul Hughes

  • 5 Posts
  • 0 Reply Likes
Thanks, I managed to send out my mailing. I would love it if you can take that further look for more potential issues, and I'll try to figure out any html weirdness.

In answer to your question about logging into community, I did use the "?" button. I couldn't find any other way to get there. I guess that's because I wasn't looking for "community" but help, so that seemed like the logical path. And then at that point, whenever I chose "login with MyEmma account" (or whatever the wording was) from those options, it would weirdly just load a fresh MyEmma page in a new small window. I can try to recreate that and take a screenshot if it's helpful. [Update: Ha, this happened again, just as I was trying to submit this reply. I took a screenshot.]

And that's good to know about support@, thanks. That is a well-hidden resource, since when you're logged in, the only apparent path for help is the "?" button, and if you think to log out and look there, the Contact page also drives you to Community and doesn't offer that handle. I get the cost-effectiveness of pushing people into community first (and Apple has trained me to expect it), but it was a bummer for my first MyEmma support experience. But it was nice to find that, unlike Apple, you guys actually seem to watch fairly closely. I appreciate that you could jump into the actual mailing and find a resolution.
Photo of Emily Hollingsworth

Emily Hollingsworth, Alum

  • 2203 Posts
  • 158 Reply Likes
Hi Paul -- Thanks so much for sharing those details about your sign in process. We definitely want to make sure you're able to get logged into the community without any trouble. I looked into your user profile, and you're actually connected to the community through your Google account (I believe based on how you singed in the first time). So, the easist way to get logged in would be to choose the "Sign in with Google" option below:



That being said, you should still be able to log in via the Emma option and connect your account. I'll keep digging on that front. Thanks!
Photo of Sam Collis

Sam Collis, Customer Support Specialist

  • 252 Posts
  • 59 Reply Likes
Hi Paul,

We've taken a further look into this and it turns out it isn't those special characters alone that are causing the issue.  It's the special characters in combination with some older image links that are in the mailing that are causing the error. This is indeed a very unique set of circumstances at play.

We've set up a new mailing, "Support - October 2015 - COPY 10.28.15," and replaced all of the old image links with updated S3 links (while retaining the special characters), and the mailing sent just fine. And, you can send just fine with the old image links as long as those special characters aren't in there as well.  Feel  free to use the Support copy as a reference.

That should sort out any sending issues with that template!
(Edited)