Why does it take so long for test emails to be delivered?

  • 0
  • 1
  • Question
  • Updated 6 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Resolved

After creating an email campaign and sending a test message to various recipients--or even just myself--it can take an hour or more before the test message appears in everyone's/my in box. Why is this?
Photo of The Library Resources Group

The Library Resources Group

  • 3 Posts
  • 1 Reply Like
  • frustrated

Posted 6 years ago

  • 0
  • 1
Photo of Tyler Scott

Tyler Scott, Employee

  • 805 Posts
  • 39 Reply Likes
Hello! Sorry for the troubles on those test emails. Looking at your response page, I see you're sending those tests to folks with the same domain name as your "from" email address (internally).

With that being said I think what you're running into here is a whitelisting issue, which is a pretty common problem with an easy solution. The problem is that your server is seeing an inbound email claiming to be from your domain, but the message is actually coming from an external domain (e2ma.net). The solution is to whitelist Emma's sending domain, e2ma.net, so that the server knows we are a trusted site and that we are safe to send on your behalf. Just get in touch with your server administrator and they should be able to take care of this without a problem. Here's a link you can pass along with all the details they'll need to know:

http://myemma.com/resources/how-to/ho....

Hopefully this helps speed up the delivery of those tests, but please let me know if I can assist further.